dhcp issue

Unanswered Question
Mar 27th, 2009
User Badges:

Hello mates!


I've got a strange issue that I haven't encountered before. What's happening is a particular ssid allows an association, but will not provide a dhcp address. Now, I have another ssid on the same controller, pointing to the same dhcp server, but different scope and it pulls dhcp fine for the clients. The ssids are in two differnt vlans. Both vlan interfaces contain an ip helper address. Both interfaces on the WLC contain a dhcp server address as well. Under the ssid's, advanced tab, they have the option for dhcp assignment required checked. So both setups look exactly the same. I can ping the dhcp server from the vlan with the ssid in question, so reachability isn't the issue. I've tried disabling the dhcp proxy feature on the WLC, but no go. The only difference that I can find is at the switch level. Keep in mind this is a wism. The ssid that I'm having the trouble with is on vlan 78, and on the switch it is set for the native vlan connecting back to the wism for the internal gig interfaces. shewww...any idea?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Fri, 03/27/2009 - 18:31
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

If you plug a wired host/client into a switch and configure to the same VLAN, do you still get an invalid IP Address?


On the configuration for the 6500 chassis and the WiSM, do you have the VLAN's enabled and allowed?


Are you using H-REAP?

Matthew Ratliff Tue, 03/31/2009 - 07:11
User Badges:

I'm not using HREAP.


Yes, I can plug a wired client in and get an ip.


The vlans are enabled and allowed.

Scott Fella Sat, 03/28/2009 - 20:35
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 Wireless

Your management and ap managers should be set on the wlc's as vlan "0" and what ever vlan they are on should be the one set to native vlan. It is best practice. All your dynamic interfaces should be tagged and you also should verify that you are allowing all your vlans on your etherchannel.

jeff.kish Tue, 03/31/2009 - 07:58
User Badges:
  • Silver, 250 points or more

What type of security are you using? If you're using WEP, and you have the wrong key configured, clients will be unable to DHCP.

Matthew Ratliff Tue, 03/31/2009 - 09:27
User Badges:

I found the fix.


What I had to do was go in and toggle the security under Layer2. Strange, but I switched it from static wep to wpa2 then back. That corrected the issue.

Actions

This Discussion

 

 

Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode