Multicast streaming only works for 255 secondsm but wait there is more....

Unanswered Question
Mar 29th, 2009
User Badges:

Good Morning,


We suddenly started having problems multicasting from our Internet2 connection last month, In the past two weeks we have had two conference calls with Cisco TAC totaling 9 hours. We have them stumped so far.


The problem we have is we can only stream videos for a short period and then they just stop working. On our first call with TAC they determined if I do a "clear ip igmp group" I can stream again for a short period. Just clearing igmp for the source stream doesn't help we have to do all the igmp groups.


This morning it occured to me (and I don't know why we didn't think of this sooner) is to clock exactly how long I can play a multicast stream. What I found suprised me.


Multicast streaming stops working 255 seconds after I last clear the IGMP tables. This is significant because as I understand it 255 is the default time to live for multicast traffic. I did the test multiple times running a stopwatch and the results are the same every single time.

If I clear the IGMP tables and wait 195 second before streaming I only get 60 second of streaming. So it is not that clearing the tables lets me stream for 255 seconds whenever I choose but rather my window for streaming anything is 255 seconds from the time I clear the table, period.


Any thoughts!!


Thank You,

Joe


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
JamesLuther Sun, 03/29/2009 - 06:04
User Badges:
  • Silver, 250 points or more

Hi,


Have you done a packet capture to see if your are seeing igmp join/leave messages?


Also have you tried using static igmp join ie


ip igmp static-group 239.0.0.1


This may help you narrow down if it's a client issue or further upstream.



Regards

joeisbell Sun, 03/29/2009 - 06:20
User Badges:

Thanks for thre quick reply James.


The static IGMP join gives the same results.. video only plays for 255 seconds. I just tried it again.


Regarding the packet capture... I don't remember for certain but I don't *think* we were getting leave requests once the 255 seconds hit.


Thanks,

Joe


Giuseppe Larosa Sun, 03/29/2009 - 06:22
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Joe,

the TTL is expressed in router hops only in the early days it was thought to be a time measure.


However, as already suggested you need to understand where the process fails:

if there is a missing of IGMP reports from receivers.

if it is the PIM join to the upstream router to be missing.


Hope to help

Giuseppe


joeisbell Sun, 03/29/2009 - 06:28
User Badges:

Giuseppe,


Yes I know TTL is expressed in router hops but I am just trying to figure out what else I can relate to the 255 seconds of it working. Maybe somehow the the TTL is increasing once a second... I don't know. My mutlicast threshold is set to 0 on my router so this should be ok.


Interestingly enough Cisco TAC seemed to think our our first call that Layer 2 on on metro ethernet saw the appropriate traffic but that it wasn't being communicated to layer 3 properly unless we cleared the IGMP tables.


Thanks again... will keep everyone informed.


Joe


Actions

This Discussion