MGCP Gateway unexpected failover

Unanswered Question
Mar 29th, 2009

Call manager 4.2, two subscribers, 1 publisher

We are currently have 30 mgcp isr gateways 2 are used for PSTN connectivity and the others for srst, 911 and analog ports.

Five days ago five of the SRST gateways started intermittently failing over to the backup CM Subscriber, then instantly failing back. This has occurred a total of 14 times.

I am perplexed as to what would be causing this issue. We have examined the network logs as well as the gateway configuration and nothing is out of the ordinary. The only call manager changes that have been made over the last fives days are move, add, changes.

Any help would be appreciated

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nicholas Matthews Sun, 03/29/2009 - 20:44

Frequently this is caused by network issues. The TCP backhaul channel is probably flapping.

This can be caused by bugs or by network problems.

I would make sure that TCP 2428 is prioritized over your WAN, and if you're worried, start running a packet capture on the interface along with some MGCP debugs in case you need a TAC case.

It may be worth upgrading to a more recent version to rule out possible bugs.


afischer1 Mon, 03/30/2009 - 05:16

Is TCP backhaul used for all MGCP gateways? I thought it was only used for BRI connectivity.

I just went through all our application logs on the ccm servers and i noticed some phones have been unregistering and registering at off hours for quite some time. It appears that they are suffering from the same issue as the gateways.

I already have debug mgcp events running on the gateways that have started re-registering and i havent been able to catch one re-register yet.

CMM 4.2(3)sr4a

Nicholas Matthews Mon, 03/30/2009 - 07:00

Yes, it's used for all gateways. It's used to monitor registration for all gateways, and to pass ISDN messaging for BRI/PRI circuits.

It sounds like you have network connectivity problems. I would solve that first and worry about the finer points of MGCP registration later :)


afischer1 Sat, 04/04/2009 - 14:20

Well i finally figured out what was happening. We ran a debug MGCP events and saw that the mgcp kill alives were arriving just before the failover. We also ran detailed trace on the call manager and saw that the mgcp kill alives were arriving just before the failover. So I decided to perform a cluster reboot and what ya know it fixed the problem.

Thanks windows for the mystery reregistration issue.

Thanks for all your help nick.


This Discussion