Message error on Cisco Router

Unanswered Question
Mar 30th, 2009
User Badges:

I add on Cisco Router, a 4 Fast Ethernet module (HWIC). I want to configure then interfaces but when I assign a IP address I have this message :


% IP address maybe not configured on L2 links.


I don't understand why this card doesn't apply IP parameters whereas i look them on the running config !!


For informations :

Router type : 3845

IOS : IP-voice-k9 or IP-base


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lamav Mon, 03/30/2009 - 08:04
User Badges:
  • Blue, 1500 points or more

Maxime:


1.) An HWIC card is a High-speed Wan Interface Card, not a a FastEThernet card.


2.) can you post the outputs of a "show ver", "show hard" and "sh diag"?

Leo Laohoo Mon, 03/30/2009 - 14:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    The Hall of Fame designation is a lifetime achievement award based on significant overall achievements in the community. 

  • Cisco Designated VIP,

    2017 LAN, Wireless

HWIC-4ESW is purely a Layer 2 switch. You can't assign an IP Address to any of the ports.

Edison Ortiz Mon, 03/30/2009 - 15:00
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Maxime,


As Leo indicated, the module provides Layer2 switchports to which you can assign a vlan to it. If you need to assign an IP address to that vlan, you must do it at the Switch Virtual Interface (SVI) level.


For instance, for creating vlans in this router you execute:


router#vlan database

router(vlan)#vlan 2

router(vlan)#vlan 3

router(vlan)#exit


Then create the Layer3 representation from those Vlans:


interface Vlan 2

ip address 192.168.2.1 255.255.255.0


interface Vlan 3

ip address 192.168.3.1 255.255.255.0


then you go to the ports


int fx/2

switchport access vlan 2


int fx/3

switchport access vlan 3


HTH,


__


Edison.

maxime.chevet01 Tue, 03/31/2009 - 00:43
User Badges:

Thanks guy's for your response.


Effecively I test, using the vlan method and it works !! thanks edison


I don't think to put the sh vers because the problem is solved but thanks.


So if I correctly Understand, To assign IP address normally without using VLAN I have to purchase a Card with Interface on Layer 3 ??


Another question in relationship with this card :


The situation :


On this L2 card I apply edison's method. The IP address is a default gateway on the vlan2 and the link go to the switch which have already lot of VLAN.


Question :

If paquets are tagged with vlan 51 by the switch, when it arrive on the gateway interface what TAG will take it ??



t-yamashita Tue, 03/31/2009 - 01:48
User Badges:
  • Gold, 750 points or more

If gateway interface is vlan2 of SVI,It will drop tagged packet of vlan51.


If you want to receve and transfer it on SVI with HWIC,you need to do as follows.


router#vlan database

router(vlan)#vlan 51

router(vlan)#exit


interface Vlan 51

ip address 192.168.51.254 255.255.255.0


interface FastEthernet0/0/0

switchport mode trunk

Edison Ortiz Tue, 03/31/2009 - 06:18
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Question :

If paquets are tagged with vlan 51 by the switch, when it arrive on the gateway interface what TAG will take it ??


Per the configuration I posted, you aren't tagging packets with Vlan ID information. Vland ID information is included on 802.1q packets.


If this switch module is connected to a regular switch that has access vlan 51, it will work. You may get some CDP messages about Vlan mismatch but that's due to CDP carrying information about the 'native vlan' when discovering neighbors. You have 2 options on this case; a) Disable CDP on both ends b) match the Vlan ID.


You can create Vlan 51 in the switch module to make it compatible to your regular environment but it isn't a 'must'.


HTH,


__


Edison.

Actions

This Discussion