SWITCH_QOS_TB-5-TRUST_DEVICE_LOST

Unanswered Question

Why do I get this error message on one of my switches? When it happens it knocks the port out anywhere from a few minutes to a few hours. Here is the config for the port:

switchport access vlan 50

switchport trunk encapsulation dot1q

switchport trunk native vlan 50

switchport mode trunk

switchport voice vlan 20

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape 10 0 0 0

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

spanning-tree guard root

mark gibson

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
htarra Sat, 04/04/2009 - 20:03

Error Message seems SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: [char] no longer detected on port

[char], port set to untrusted

Explanation : The system lost contact with a trusted device and changed the trust state for the interface to untrusted.

Recommended Action : This is an informational message only. No action is required.

DENNIS WEIKEL Sun, 04/24/2016 - 12:22

Has anybody found a solution to this issue.  

I'm experiencing with Cisco IOS-XE 3850 software running the latest IOS release 03.06.04.E

Are there debugging commands that can pinpoint the issue.  

Thanks in advance.

Dennis 

BlueyVIII Mon, 05/23/2016 - 13:00

Hi Dennis - We didn't get to the bottom of it, and in the end our users complained that much we had to replace all the 7942 phones with 7821 models. This stopped the issue occurring but we never got to the root cause!

Fortunately we didn't have many phones to replace :)

Marwan ALshawi Sun, 04/05/2009 - 03:59

by the way

i see you have your port assigned to vlan 50

and then you have switchport mode trunk

why you did it like this

just rmove the mode trunk no reason for it here

ankgarg_99 Sun, 01/19/2014 - 23:37

we are facing the issue with IP phones and they lost connectvity and start upgrading.

found some errors on the switch logs,

TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi7/2, operational port trust state is now untrusted.

Jan 17 15:03:05: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi7/11, operational port trust state is now untrusted.

Jan 17 15:06:44: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/42, port's configured trust state is now operational.

Jan 17 15:08:51: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/23, port's configured trust state is now operational.

Jan 17 15:33:57: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/10, port's configured trust state is now operational.

Jan 17 15:39:19: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/9, port's configured trust state is now operational.

Jan 17 15:41:20: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/13, port's configured trust state is now operational.

Jan 17 15:41:29: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/7, port's configured trust state is now operational.

Jan 17 15:50:59: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/30, port's configured trust state is now operational.

Jan 17 15:51:34: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/37, port's configured trust state is now operational.

Jan 18 02:01:31: %SYS-5-CONFIG_I: Configured from 10.14.2.10 by snmp

Jan 18 05:35:08: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi8/15, operational port trust state is now untrusted.

Jan 18 05:36:21: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi8/15, port's configured trust state is now operational.

Jan 18 07:31:38: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi1/45, operational port trust state is now untrusted.

Jan 18 07:33:01: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi1/26, operational port trust state is now untrusted.

Jan 18 07:34:58: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi9/7, operational port trust state is now untrusted.

Jan 18 07:35:37: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/11, port's configured trust state is now operational.

Jan 18 07:40:27: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi1/45, port's configured trust state is now operational.

Jan 18 07:45:41: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi1/43, port's configured trust state is now operational.

Jan 18 07:51:43: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi3/3, operational port trust state is now untrusted.

Jan 18 07:51:58: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi2/48, operational port trust state is now untrusted.

Jan 18 07:55:48: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi2/48, port's configured trust state is now operational.

Jan 18 07:56:48: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi3/3, port's configured trust state is now operational.

Jan 18 09:04:33: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi3/3, operational port trust state is now untrusted.

Jan 18 09:09:09: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi1/45, operational port trust state is now untrusted.

Jan 18 10:16:21: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi1/1, operational port trust state is now untrusted.

Jan 18 10:17:43: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi1/1, port's configured trust state is now operational.

Jan 20 03:34:13: %SWITCH_QOS_TB-5-TRUST_DEVICE_LOST: cisco-phone no longer detected on port Gi7/9, operational port trust state is now untrusted.

Jan 20 03:35:17: %SWITCH_QOS_TB-5-TRUST_DEVICE_DETECTED: cisco-phone detected on port Gi7/9, port's configured trust state is now operational.

show run int gig8/15

Building configuration...

Current configuration : 236 bytes

!

interface GigabitEthernet8/15

switchport access vlan 1132

switchport mode access

switchport voice vlan 1162

qos trust cos

qos trust device cisco-phone

tx-queue 3

   priority high

   shape percent 33

spanning-tree portfast

end

Need help.

jfmontuir Thu, 02/06/2014 - 02:20

Hi

I have the same problem. Do you have a solution?

Do you have tried to put a power injector behind the IP IPhone and test if the problem still appears ? 

What are the tests that were performed for the moment?

Thanks in advanced for your help.

BlueyVIII Fri, 12/12/2014 - 05:02

Hi - Did you ever get a solution to this problem as we're experiencing the exact same issues running the same version of 3750 and 7942 code?

 

If you solved the problem I'd be interested to hear what you did.

 

Thx.

Actions

This Discussion