incoming calls from PBX to UC520 over Ti ISDN- PRI receive dial tone

Unanswered Question
Mar 30th, 2009
User Badges:

Need to intercept incoming calls from PBX through the T1 connection and provide

routing rules based on the incoming number. Right now incoming calls receive dial tone from UC520

which is the best way to accompligh this?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Marcos Hernandez Mon, 03/30/2009 - 15:12
User Badges:
  • Blue, 1500 points or more

Check out this quick article:


https://www.myciscocommunity.com/docs/DOC-5286


On the dial tone issue, make sure your POTS dial peers (mapped to the PRI), have the following command "direct-inward-dial". CCA should be doing this by default.


Thanks,


Marcos Hernandez
Technical Marketing Engineer
Cisco Systems, Inc.

JMadrugaADM Mon, 03/30/2009 - 15:20
User Badges:

Thanks Marcos, in my case I'm routing DIDs from my PBX to the UC520 this are 4 digit stations. I need to do digit translation here

for example and incoming station 3939 needs to ring on IP phone ext 702

Marcos Hernandez Mon, 03/30/2009 - 15:28
User Badges:
  • Blue, 1500 points or more

This should be easy to do with the CCA inbound call routing/DID rules. Or do you need the CLI equivalent? In that case, something like this would work (shown for 2 numbers):


!
voice translation-rule 10

rule 1 /3938/ /702/
!

voice translation-rule 11

rule 1 /3939/ /702/
!
voice translation-profile First_DID
translate called 10
!
voice translation-profile Second_DID
translate called 11

!

dial-peer voice 10 pots

translation-profile incoming First_DID

incoming called-number 3938

direct-inward-dial

!

dial-peer voice 11 pots

translation-profile incoming Second_DID

incoming called-number 3939

direct-inward-dial

!



Marcos

JMadrugaADM Tue, 03/31/2009 - 06:33
User Badges:

Hi Marcos, I try these settings and it didn't work. The calls from the PBX just receive dial tone.

under the dial peer do I have to assign a port in this case like 0/2/0:23?

Is it possible to change the dial plan on the uc520 to match the PBX extations?

Marcos Hernandez Tue, 03/31/2009 - 06:39
User Badges:
  • Blue, 1500 points or more

You are getting dial tone because there are other POTS dial-peers with similar config that do not have "direct-inward-dial" configured. It is a good idea to add the port, I omitted that (although it is not strictly necessary for inbound dial peer matching).


Make sure that the only POTS dial peers with "incoming called-number" and "direct-inward-dial" are the ones you created following my configuration. Let me know how that works.


Marcos

JMadrugaADM Tue, 03/31/2009 - 10:31
User Badges:

Hi Marcos, the problem was on the PBX side with the route pattern.

It is now working great.


thanks

jaime

Actions

This Discussion