E1 Outgoing call Problem

Unanswered Question
Mar 31st, 2009

Hello everyone,

I have this strange problem with an E1 line. I have a CM 4.2 and a voice gateway (2811) with IOS 12.4.16 SP Services

I configured the typical E1 configuration for MGCP, however while testing it i found out the following.

- Incoming calls are working fine.

- Outgoing calls are disconnected almost instantaneously as soon as it hits the voice gateway router.

I don't hear a ringback or anything, it would look as if it would be "connected" then it's cut off.

I have a new Region and Device Pool Configured, I had both the phone I'm testing from and the gateway in the same DP. I tried both codecs actually (G.729) and G.711, it woud work fine in the incoming, but i couldn't get the outgoing to work.

I configured even a HW Transcoder on the router and it's registered in the same device pool but still, same results.

I would get in the debug the following error, which is very strange

"Cause i = 0x82C1 - Bearer capability not implemented"

Following is some of my configuration applied.

!

controller E1 0/1/0

pri-group timeslots 1-31 service mgcp

!

!

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

no logging event link-status

isdn switch-type primary-net5

isdn incoming-voice voice

isdn bind-l3 ccm-manager

isdn sending-complete

no cdp enable

!

!

voice-port 0/1/0:15

bearer-cap Speech

!

dial-peer voice 99999 pots

service mgcpapp

direct-inward-dial

port 0/1/0:15

!

The debug out put is as follows:

*Mar 31 15:04:54.922: ISDN Se0/1/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=48

*Mar 31 15:05:03.518: ISDN Se0/1/0:15 Q921: User TX -> INFO sapi=0 tei=0, ns=48 nr=62

*Mar 31 15:05:03.518: ISDN Se0/1/0:15 Q931: SETUP pd = 8 callref = 0x0012

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98397

Exclusive, Channel 23

Calling Party Number i = 0x0081, '800'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '24017484'

Plan:Unknown, Type:Unknown

*Mar 31 15:05:03.530: ISDN Se0/1/0:15 Q921: User RX <- RR sapi=0 tei=0 nr=49

*Mar 31 15:05:03.538: ISDN Se0/1/0:15 Q921: User RX <- INFO sapi=0 tei=0, ns=62 nr=49

*Mar 31 15:05:03.538: ISDN Se0/1/0:15 Q931: RELEASE_COMP pd = 8 callref = 0x8012

Cause i = 0x82C1 - Bearer capability not implemented

*Mar 31 15:05:03.542: ISDN Se0/1/0:15 Q921: User TX -> RR sapi=0 tei=0 nr=63

*Mar 31 15:05:13.534: ISDN Se0/1/0:15 Q921: User RX <- RRp sapi=0 tei=0 nr=49

*Mar 31 15:05:13.538: ISDN Se0/1/0:15 Q921: User TX -> RRf sapi=0 tei=0 nr=63

*Mar 31 15:05:23.534: ISDN Se0/1/0:15 Q921: User TX -> RRp sapi=0 tei=0 nr=63

*Mar 31 15:05:23.534: ISDN Se0/1/0:15 Q921: User RX <- RRp sapi=0 tei=0 nr=49

*Mar 31 15:05:23.538: ISDN Se0/1/0:15 Q921: User TX -> RRf sapi=0 tei=0 nr=63

*Mar 31 15:05:23.538: ISDN Se0/1/0:15 Q921: User RX <- RRf sapi=0 tei=0 nr=49

I even checked with the Teleco, and they told me that everything is fine as well...

Does anybody have an idea, what is wrong here?

thanks and best regards,

Ahmed El-Eraky

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Nicholas Matthews Tue, 03/31/2009 - 15:44

Hi Ahmed,

There a few things you can try doing:

1) Send a fully defined calling number. Many carriers disconnect with an incomplete calling number

2) Change format of called number (add area code, 1, etc)

3) You could try adding "##BC=3.1kHz##" in the description field of the endpoint (PRI) to change the bearer cap.

hth,

nick

AhmedEl-Eraky Fri, 04/03/2009 - 09:26

Nick,

Thanks for your response.

I did try adding a fully qualified calling number but stil no change. I removed the calling party transformation mask completely and it still didn't work.

I had to call the Telecom people and they changed some parameters on the modem, and it didn't work on MGCP.

However, it was solved after changing to H323, and strangely it worked!!!

I am not sure what was wrong exactly, any ideas?

Thanks and best regards,

Ahned El-Eraky

lordshawn Fri, 04/03/2009 - 14:42

I think on the MGCP configuration you can adjust the switch type...and there is another setting for setting the call type. I think you must have been using "Cisco Call Manager". Trying changing to national..etc.

Nicholas Matthews Fri, 04/03/2009 - 18:45

Hi Ahmed,

The Plan: and Type: configuration are automatically chosen in CUCM based on the NANP. The gateway does some as well, but it differs based upon the switch type and such.

It was probably a difference in the Plan:Type: for either the calling/called number.

Everything else is mostly the same between MGCP and H323.

-nick

Actions

This Discussion