Eompls connectivity issue between Me-6524 and 7606-S

Unanswered Question
Mar 31st, 2009
User Badges:

my problem is one side vc is up and the other side was down when I configure EoMPLS the configuration like this


ME-6524

interface GigabitEthernet1/13

switchport

switchport access vlan 101

switchport trunk encapsulation dot1q

switchport mode trunk

end


interface Vlan101

no ip address

xconnect 10.1.1.3 101 encapsulation mpls

end


K24#show mpls ldp neighbor

Peer LDP Ident: 10.1.1.3:0; Local LDP Ident 10.1.1.5:0

TCP connection: 10.1.1.3.646 - 10.1.1.5.19798

State: Oper; Msgs sent/rcvd: 109/114; Downstream

Up time: 00:27:48

LDP discovery sources:

Targeted Hello 10.1.1.5 -> 10.1.1.3, active, passive

GigabitEthernet1/25, Src IP addr: 10.1.35.3

Addresses bound to peer LDP Ident:

10.1.1.3 30.1.78.113 10.1.13.3 10.1.23.3

10.1.39.3 10.1.37.3 10.1.36.3 10.1.34.3

10.1.35.3



K24#show mpls ldp bind 10.1.1.3 32

lib entry: 10.1.1.3/32, rev 126

local binding: label: 75

remote binding: lsr: 10.1.1.3:0, label: imp-null

remote binding: lsr: 10.1.1.4:0, label: 23

K24#show mpls for 10.1.1.3 32

Local Outgoing Prefix Bytes Label Outgoing Next Hop

Label Label or Tunnel Id Switched interface

75 Pop Label 10.1.1.3/32 0 Gi1/25 10.1.35.3

K24#




K24#show mpls ldp bind 10.1.1.3 32

lib entry: 10.1.1.3/32, rev 126

local binding: label: 75

remote binding: lsr: 10.1.1.3:0, label: imp-null

remote binding: lsr: 10.1.1.4:0, label: 23

K24#show mpls for 10.1.1.3 32

Local Outgoing Prefix


K24#show mpls l2 vc


Local intf Local circuit Dest address VC ID Status

------------- -------------------- --------------- ---------- ----------

Vl101 Eth VLAN 101 10.1.1.3 101 DOWN

K24#



C7609-S-1(ME6524 connected to ES 2/0/15,2/0/16)


!

l2 vfi VPLS101 manual

vpn id 101

neighbor 10.1.1.4 encapsulation mpls

neighbor 20.1.1.1 encapsulation mpls

neighbor 40.1.1.5 encapsulation mpls

neighbor 40.1.1.6 encapsulation mpls

neighbor 10.1.1.5 encapsulation mpls no-split-horizon

!

interface Vlan101

no ip address

xconnect vfi VPLS101

end

KPE1#show mpls l2 vc destination 10.1.1.5 detail

Local interface: VFI VPLS101 VFI up

MPLS VC type is VFI, interworking type is Ethernet

Destination address: 10.1.1.5, VC ID: 101, VC status: up

Output interface: Gi2/0/15, imposed label stack {80}

Preferred path: not configured

Default path: active

Next hop: 10.1.35.5


KPE1#show mpls for 10.1.1.5 32 detail

Local Outgoing Prefix Bytes Label Outgoing Next Hop

Label Label or VC or Tunnel Id Switched interface

107 Pop Label 10.1.1.5/32 0 Gi2/0/15 10.1.35.5

MAC/Encaps=14/14, MRU=1504, Label Stack{}

0019AA55670E001CB0CB99C08847

No output feature configured

KPE1#

KPE1#show mpls l2 vc


Local intf Local circuit Dest address VC ID Status

------------- -------------------------- --------------- ---------- ----------

VFI VPLS101 VFI 10.1.1.5 101 UP




the problem is On 6524, when I invoke the show mpls l2 vc 101 detail.


the next-hop marked " Next hop: Invalid ADDR"


Why?.. Why not up on ME6524

the mpls ldp bind ok, forwarding ok,

when I do show ip route on ME6524, It was ok.


Help me..


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 03/31/2009 - 13:15
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Seungyeop,


first of all I would change config of port g1/13



int gi1/13

switchport mode access


so that it is clear you have a port in Vlan101 in STP forwarding state.


Hope to help

Giuseppe


syjeon Tue, 03/31/2009 - 15:25
User Badges:

I'd deleted switchport mode access,


and I made a trunk port in gi 1/13


but the symptom is same thing like before.


Do you have a another action plan?

Harold Ritter Tue, 03/31/2009 - 19:43
User Badges:
  • Cisco Employee,

Seungyeop,


Configuring the xconnect on an SVI interface enables local switching and requires additional hardware. On the 7609, the ES20 enables you to do that.


The solution would be to configure the xconnect under the physical interface on the ME6524.


Regards

kiwlee Wed, 04/01/2009 - 11:42
User Badges:
  • Cisco Employee,

Hi Ritter,


Thank you for your reply.


We are testing H-VPLS. On the testing, we met upper problem, When we change to ME3750 from ME6524, it looks fine. So, we assume it would be ME6524 issue. BTW,In 6524 datasheet on cisco web, ME6524 also can support MPLS VC Type 4. I am confusing what is correct. So I need helps experts.(looks like you :-)


Unfortunately, We should use MPLS VC type-4 on ME6524 with H-VPLS. :-(


CE-UPE(6524)-NPE(7606-S)-P(GSR)-P(GSR)-PE-NPE(7609)-UPE(6524)


Your help in this issue will be appreciated.


Thanks,


Kiwon,Lee

Advanced Services.

Harold Ritter Wed, 04/01/2009 - 12:41
User Badges:
  • Cisco Employee,

Kiwon,


You can use VC type 4 on the ME6524. You need to configure the xconnect statement under a dot1q subinterface as follow:


interface GigabitEthernet1/13.101

encapsulation dot1q 101

xconnect 10.1.1.3 101 encapsulation mpls


Regards

Harold Ritter Wed, 04/01/2009 - 12:41
User Badges:
  • Cisco Employee,

Kiwon,


You can use VC type 4 on the ME6524. You need to configure the xconnect statement under a dot1q subinterface as follow:


interface GigabitEthernet1/13.101

encapsulation dot1q 101

xconnect 10.1.1.3 101 encapsulation mpls


Regards

kiwlee Thu, 04/02/2009 - 11:05
User Badges:
  • Cisco Employee,

Hi Ritter,


It looks fine after change config. I assume that it is normal. It would be better for customer.


Thank you very much.


Kiwon.


Actions

This Discussion