CVP comprehensive, CM over WAN

Unanswered Question
Mar 31st, 2009

SIDE A:

UCCE 7.5

Callmanager 6.1 Publisher, Subscriber 1

CVP A server

AWDB/HDS/Webview

SIDE B:

voice gateway 2851

UCCE 7.5

Callmanager Subscriber 2

CVP B server

ipcommunicator

protocol is SIP for all systems.

Agents login to ipcommunicators at side B location and ipcommunicators register to side B subcriber 2. Side B is connected to Side A over WAN i.e, callmanager cluster is distributed over WAN between side A and side B.

Customer calls a tollfree number and lands in side B voice gateway. Welcome prompt is played from CVP B server and when customer opts for agent transfer

call gets transferred to agents at side B thru callmanager subscriber 2. We dont have any issues at side B.

The issue is, when the subscriber 1 or callmanager publisher at side A is switched on, we get a one way audio i.e, caller can hear agent talking but agent does not hear the caller, caller's voice is echoed back to him.

All switch ports and all servers are full duplex and we are able to ping all servers at both locations. When we switch off side A callmanager publisher and subscriber 1 the call flow is fine. Effectively side B seems to run fine but when side A (callmanager publisher and subscriber 1) is switched on we have this one way audio problem.

Both call servers have static route pointing to side B callmanager subscriber 2.

Appreciate your suggestions..

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

You don't list the SIP Proxy, and you say that "both call servers have static route pointing to side B callmanager subscriber 2" so I have to assume no proxy.

When a call comes into the gateway, it chooses a CVP (how? preference dial peers?).

I assume you use "Send To Originator" to push the call back to the ingress gateway (combine g'wy).

When the agent becomes available, how does CVP find a subscriber? Without CUPS you have static routes in CVP. Do you have static routes to both subs? (you only mention one).

Without CUPS you have a SIP trunk to the CVPs. This trunk is in a device pool. Your phones are in a device pool. Any misaligment?

Regards,

Geoff

rafi.imran Tue, 03/31/2009 - 23:12

Hi Geoff,

1. Yes you are right, theres no proxy.

2. Yes preference dial-peer with the first one pointing to CVP at side B

3. I am not using send to originator but

sending the VRU label by adding a static route pointing to gateway. I am not sure if this is the cause of the problem.

4.I have static route pointing to subscriber 2 at sideb. This has been done in both call servers.

5.Yes sip trunks, I am using default device pool for all phones and sip trunks.

I don't know what the problem is yet, so let me ask a couple more questions.

1. Call comes in on VGB.

2. First preference dial peer activates and sends the call to CVPB

3. A static route on CVPB sends the VRU label back to VGB.

This implies that CVPB has only one static route for the transfer label - and it points to VGB. Is this correct?

Do you likewise have CVPA configured with a single static route to VGA? The problem with this is that should the first preference dial peer fail because CVPB is down, the second preference dial peer will send the call to CVPA. If it just has a static route to VGA, the vru leg will run on VGA and now you have an RTP stream between the ingress gateway VGB and the VXML gateway VGA. Undesirable.

Again, if you have two static routes in CVPB for the transfer label one pointing to VGB and one pointing to VGB, every other call will be sent to VGA to run the vru leg.

Send To Originator resolves this problem and the VRU leg will always run on the ingress gateway. You probably want this.

Sometime later, an agent becomes available and the agent extension label is returned to CVPB. It looks at the static routes and there is one, and it only goes to SUBB. What if SUBB is down? Don't you want to have a pair of static routes going to SUBB and SUBA?

On the PG configuration, do you have the JTAPI gwy on PGA pointing to SUBA and the CTI Manager process is running there? Similarly, does the JTAPI gwy on PGB point to SUBB and the CTI Manager process is also running on that Subscriber?

Regards,

Geoff

rafi.imran Wed, 04/01/2009 - 06:14

1.Correct, CVPB has one static route pointing to VG. VG is available only in sideB location, theres no VG in sideA location.

2.CVPA has a static route pointing to VG at sideB.

3.One static route pointing to SUBB from both callservers CVPA and CVPB. Actually I wanted to add another route pointing to SUBA, but as explained whenever i start SUBA we have one way audio issue hence I thougt I would remove this route as of now pointing to SUBA.

4.Yes, sideA PIM pointing to SUBA and sideB PIM pointing to SUBB. Failover is also fine. CTI Manager processes are running in all three nodes (PUBA,SUBA,SUBB)

I see. You actually had that in your first post - the fact that you only have one gateway, and it's located at side B. This is your lab system, right?

You don't need CTI Manager on the Pub. A small point.

It seems like you have the bases covered. I don't know what your problem is, but I have certainly had my share of one way audio problems. You need to look at some logs or something. If it's too hard, you should ask TAC for help.

Regards,

Geoff

Actions

This Discussion