QOS on 3560 12.2(35)

Unanswered Question
Apr 1st, 2009


I'm trying to configure qos for the first time.

My configuration is as follows:

mls qos

access-list 100 permit udp any any range 16384 32767

class-map match-any rtp-stream

match access-group 100

Policy-map voice

class rtp-stream

set dscp ef

interface fa0/41

service-policy input voice

#show mls qos

QoS is enabled

QoS ip packet dscp rewrite is enabled

The issue is that I don't think it's working.When I issue a show access-list 100 there are no hits. Although there are phones on this port, making calls.

Does anyone know where I have gone wrong please?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
bigcappa1 Wed, 04/01/2009 - 14:22


You need a bit more config. But I do remember that certain IOS images had a bug where the QOS policy worked but the stats did no increment. If you want to prove it works use a sniffer sucha as wireshark, set up a span session and check that you can see the DSCP value

The sort of config you can have as based on the QoS SRND for the 3560 could be

mls qos

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos map policed-dscp 0 24 to 8

class-map VVLAN-VOICE

match access-group name VOICE


match access-group name SIGNALING

class-map VVLAN-ANY

match access-group name VOICE-ANY

ip access-list extended VOICE

permit udp any range 16384 32767

ip access-list extended SIGNALING

permit tcp any range 2000 2002

ip access-list extended VOICE-ANY

permit ip any

policy-map IPPHONE


set ip dscp 46

police 128000 8000 exceed-action drop


set ip dscp 24

police 32000 8000 exceed-action policed-dscp-transmit


set ip dscp 0

police 32000 8000 exceed-action policed-dscp-transmit

class class-default

set ip dscp 0

police 5000000 8000 exceed-action policed-dscp-transmit

interface FastEthernet0/1

switchport mode access

switchport access vlan XXX

switchport voice vlan YYY

service-policy input IPPHONE

spanning-tree portfast

Data Traffic will just be treated as normal. The first part of the policy map permits only one voice call and remarks it ef, the second part remark the call control CS3 and the third part reduces any other voice traffic to scavanger value along with the default class which is the data

Hope this helps, will see ig I can find the bug id



This Discussion