HWIC-4A/S async lines as console server

Unanswered Question
Apr 1st, 2009
User Badges:

I have a 2811 with a HWIC-A/S module installed. I want setup the HWIC module so I can use the router as a console server to the other devices in this office.


I am using CAB-SS-232MT (RS232, DTE male to Smart Serial) cables connected to a "terminal"

(RS232 to RJ45) adaptor, connected to a short (3ft) network cable, and then into to the

console ports of the other devivces (all Cisco) for the physical connection.


I have included the async router config below and the "show line" output.


My problem is that when I telnet to one of the hosts by name or port number, the communication never leaves the async router.


Am I missing some serial interface config or perhaps the line numbers are wrong?




ip host RTR-host-1 2002 192.168.254.1

ip host RTR-host-2 2003 192.168.254.1

ip host SWITCH-host-1 2004 192.168.254.1

ip host ---open--- 2005 192.168.254.1



interface Loopback0

description *** Terminal Server Interface ***

ip address 192.168.254.1 255.255.255.255




interface Serial0/0/0

physical-layer async

no ip address

encapsulation slip


interface Serial0/0/1

physical-layer async

no ip address

encapsulation slip


interface Serial0/0/2

physical-layer async

no ip address

encapsulation slip


interface Serial0/0/3

physical-layer async

description *** open ***

no ip address

encapsulation slip




line 0/0/0 0/0/3

session-timeout 20

exec-timeout 0 0

no exec

transport input all




async-router#sh line

Tty Line Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int

0 0 CTY - - - - - 0 0 0/0 -

1 1 AUX 115200/115200- inout - - - 0 0 32/0 -

0/0/0 2 TTY 9600/9600 - - - - - 7 0 0/0 Se0/0/0

0/0/1 3 TTY 9600/9600 - - - - - 0 0 0/0 Se0/0/1

0/0/2 4 TTY 9600/9600 - - - - - 0 0 0/0 Se0/0/2

0/0/3 5 TTY 9600/9600 - - - - - 0 0 0/0 Se0/0/3

* 514 514 VTY - - - - - 45 0 0/0 -



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jawill47ec Mon, 02/01/2010 - 13:31
User Badges:

Hello,


I wanted to inquire to see if you found a solution to your configuration.  I am in a similiar circumstance in configuring a 2811 with a hwic-16a interface.  I haven't been able to find a specific document that speaks to the async configuration of a 2811.


thanks,

james

dkinnamon Mon, 02/01/2010 - 15:05
User Badges:

We ended up with the same config and the issue was due to a wiring issue.  I had to send new cables to the site since I had custom made some extensions.  Check the pinouts on the cables and any extension you have in place.  I had tried straight-through and crossover cables while I was onsite, but not roll-over.


Here is the key doc from TAC


----

Thanks for the update – It’s very critical that last leg RJ45 is a rollover RS232 cable.

I suspected this may be the problem because the notes show the CTS, RTS, DTS, and DTR different than from a up connection.

Check out this Guide:

https://www.cisco.com/en/US/products/hw/routers/ps332/products_tech_note09186a0080094ce6.shtml

Search for the table “Console Connection Combination”

Notice it says RJ45 Cable to console – “Rolled” and DTE need Terminal adapter – Key being the rolled RJ45 Cable.


-----




28xx Config below.



ip host rtr1 2002 192.168.254.1
ip host switch1 2003 192.168.254.1
ip host switch2 2004 192.168.254.1
ip host ---open--- 2005 192.168.254.1

interface Loopback0
description *** Terminal Server Interface ***
ip address 192.168.254.1 255.255.255.255

interface Serial0/0/0
physical-layer async
description *** TTY to rtr1 ***
no ip address
encapsulation slip
!
interface Serial0/0/1
physical-layer async
description *** TTY to switch1 ***
no ip address
encapsulation slip
!
interface Serial0/0/2
physical-layer async
description *** TTY to switch2 ***
no ip address
encapsulation slip
!
interface Serial0/0/3
physical-layer async
description *** open ***
no ip address
encapsulation slip
!

line 0/0/0 0/0/3
session-timeout 20
exec-timeout 0 0
no exec
transport input all
transport output all


sh line
   Tty Line Typ     Tx/Rx    A Modem  Roty AccO AccI  Uses  Noise Overruns  Int
      0    0 CTY              -    -      -    -    -     0      0    0/0      -
      1    1 AUX 115200/115200- inout     -    -    -     0      0   80/0      -
  0/0/0    2 TTY   9600/9600  -    -      -    -    -     0   2354    0/0    Se0/0/0
  0/0/1    3 TTY   9600/9600  -    -      -    -    -     0      0    0/0    Se0/0/1
  0/0/2    4 TTY   9600/9600  -    -      -    -    -     0      4    0/0    Se0/0/2
  0/0/3    5 TTY   9600/9600  -    -      -    -    -     0      0    0/0    Se0/0/3
*   514  514 VTY              -    -      -    -    -    10      0    0/0      -

jawill47ec Mon, 02/01/2010 - 18:20
User Badges:

Hello,


Excellent.  I appreciate the information and the quick response.  I tested via a single async line and it works as described.


thanks,

james

Actions

This Discussion