Routing Issue

Unanswered Question
Apr 1st, 2009
User Badges:

I have a triangular topology:

Location A, B & C are connected to each other over a MAN link.


Location A was connected to Location C over MAN links;

Location A :

Switch Config

interface FastEthernet7/24

description : Connecting Location B

no switchport

bandwidth 4096

ip address 10.250.254.66 255.255.255.252

speed 100

duplex full

end



& at Location B end:

Router2:

interface GigabitEthernet0/0

description : Connecting to Location C

bandwidth 4096

ip address 10.250.254.65 255.255.255.252

duplex full

speed 100

end

!



Now, I changed the configuration on Location A's switch as follows:


Location A

Switch:

interface FastEthernet7/24

switchport mode access

switchport access vlan 182

speed 100

duplex full

!


interface Vlan182

description Connecting to Location B

bandwidth 4096

ip address 10.250.254.66 255.255.255.252

!



This was the only change done. After this, location C's traffic to location B was traversing via Location A (though there is a direct link between Location B & C). Howvever location B to location C traffic is properly traversing the link between B & C.


I reverted the configuration on Location - A & checked the status,

Now location C's traffic was traversing via teh direct link to Location B.

Now, once this is working properly, I checked & realised that Location A's traffic to Location B is now traversing via Location C.


Why is this the case? EIGRP is routing protocol in use.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
Istvan_Rabai Thu, 04/02/2009 - 01:10
User Badges:
  • Gold, 750 points or more

Hi Deepa,


I don't see all your links and other config details, but I can see one thing in your config:


When you changed the routed interface from interface FastEthernet7/24 to interface Vlan182 you forgot to tell the following:


interface FastEthernet7/24

switchport


In other words, interface FastEthernet7/24 remained a layer3 port. You should make it a layer2 port with the "switchport" command.


Cheers:

Istvan

Giuseppe Larosa Thu, 04/02/2009 - 04:40
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Deepa,

EIGRP metric uses also delay and it is cumulative in delay with default K parameters settings


verify the parameters using


sh int vlan 182


sh ip eigrp int vlan 182


compares the different setups you should see some differences


Hope to help

Giuseppe


Actions

This Discussion