SPA962 in SOS Recovery Mode

Endorsed Question
Apr 2nd, 2009
User Badges:

I upgraded the firmware on my SPA962 to version 6.1.5a from version 6.1.3 and I'm now met with a phone telling me it's in SOS Recovery Mode.


How do I get my phone back to a usable state?

Endorsed by Dan Lukes
Patrick Born about 8 years 1 month ago

Hi Ivan,


I've attached the 6.1.3a recovery executable in a compressed archive file. Once you've recovered the phone, upgrade to the latest firmware from Cisco.com
https://supportforums.cisco.com/docs/DOC-9923


Regards,



Patrick

-----------

Endorsed by Dan Lukes
Patrick Born about 8 years 3 months ago

Hi Chris,


Perhaps the phone experienced a power glitch during the upgrade process.

You can recover the phone by running the attached recovery utility.


  1. Make sure that your computer and the phone are on the same subnet.
  2. You will need the phone's serial number, located on the back of the phone.
  3. Run the utility
  4. Once the phone is recovered, run the 6.1.5(a) upgrade again


Please let me know how you progress.


Regards,



Patrick

-----------

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Patrick Born Thu, 04/02/2009 - 09:13
User Badges:
  • Cisco Employee,

Hi Chris,


Perhaps the phone experienced a power glitch during the upgrade process.

You can recover the phone by running the attached recovery utility.


  1. Make sure that your computer and the phone are on the same subnet.
  2. You will need the phone's serial number, located on the back of the phone.
  3. Run the utility
  4. Once the phone is recovered, run the 6.1.5(a) upgrade again


Please let me know how you progress.


Regards,



Patrick

-----------

chris.bowra Sun, 05/24/2009 - 06:56
User Badges:

Hi Patrick,


Apologies for the delayed reply.


The utility took the phone out of recovery mode successfully. It stayed there for half an hour or an hour and then spontaneously rebooted. It has not successfully booted since. It seems to get stuck in a rut at switch one. I don't get the normal blue Linksys and subsequent screens. Symptoms vary depedning on how it feels - somethings I get 4 orange line keys and a black but backlit screen, other times a blue and grey speckeld sort of screen and various other combinations.


Any advice on how to get the phone back to a usable state?


Cheers,
Chris

Patrick Born Tue, 05/26/2009 - 12:33
User Badges:
  • Cisco Employee,

Hi Chris,


No problems about the delay, I know the feeling.

I don't understand what you mean by "It seems to get stuck in a rut at switch one. "

Can you describe step-by-step what the phone does and what is displayed on the screen when it reboots /attempts to reboot please?

Does the phone successfully request and procure an IP address from your DHCP server?

Consider running a Wireshark trace on the LAN to determine what the phone is doing when it attempts to boot.


Do you have other SPA9x2 phones in use?


Regards,



Patrick

-----------

chris.bowra Wed, 06/03/2009 - 23:31
User Badges:

Hi Patrick,


I've just switched it back on, it got sidelined.


I have a white screen and the first 4 line keys are orange.

The phone is not showing up a link light at the other end, I've tried both PC and WAN ports, so is unlikely to be able to procure an IP.

This is the only SPA phone in use.


Cheers,
Chris

Patrick Born Fri, 06/05/2009 - 08:45
User Badges:
  • Cisco Employee,

Hi Chris,


What do you mean by "it got sidelined." ?


Use an 8-wire CAT5 straight-through cable [that is, a regular CAT-5 patch cable] to connect the phone's WAN port to the switch.

Do not connect anything to the PC port because this is a switch port to connect a computer to in the event that there is only one cable in your office. [you'd remove the network cable from computer, place cable in phone's WAN port. Insert new cable to PC port and connect other end to computer]


The white screen and orange line keys indicate that the phone is not acquiring an IP address from the network. Once you've corrected the network issue which may be related to the switch you're connecting to, the phone should be fine.


Regards,



Patrick

----------

chris.bowra Wed, 06/24/2009 - 05:53
User Badges:

Hi Patrick,


The sidelined comment referred to the phone being put to the side while other more important things got attention.


I've plugged the phone into a different switch and it has recovered quite nicely.


I had only tried the PC port reckoning that if the WAN port had become faulty then the PC port might be functional.


But all works fine, thanks...

Patrick Born Wed, 06/24/2009 - 09:10
User Badges:
  • Cisco Employee,

Hi Chris,


Excellent. Thank for letting me know that the phone is now working.


Regards,



Patrick

-----------

itrubelik Fri, 06/05/2009 - 00:54
User Badges:

Dear Patrick,

I have the same problem (SOS Recovery Mode) with SPA942.

May I ask you for file with repair software for this phone?


Thank you!


Ivan

uccadenit Sat, 09/29/2012 - 01:27
User Badges:

Hi Patrick,

I have the same problem and tried to use the tool but unfortunately it shows

recovery failed: cannot find the specified device

I have connected the phone and my laptop to the switch from where both devices able to get IP from DHCP.

Please help to recover the device

Patrick Born Wed, 06/24/2009 - 09:14
User Badges:
  • Cisco Employee,

Hi Thomas,


I've attached the SPA941 recovery utility here. This recovery software also works for the SPA921 IP phone.


Regards,



Patrick

----------

linuxianer99 Wed, 01/27/2010 - 21:27
User Badges:

Hey Patrick,


i have the same Problem with a Linksys SPA922 and firmware version 6-1-5a.


Please can you send me a link to the recovery tool for this type of phone ??


Thanks a lot,

Timo

Dear Patrcik,

My phone is manufactured in 2007 . 

STORY IS 

 I am using spa 941 for few days with 5v 1.5A  power adaptor ,as i did not receive the charger from my  uk office after relocating to malaysia.

As i know i lost  the boot screen,but on few tries i get " SOS  phone in recovery mode" display

I really dont want to send the the phone back to uk main office and get it resolved the error or boot issues.


can i do it from my malaysia ? what shall i do to recover the boot and soft buttons display/


I am much frustrated.I TRIED TO OPEN THE OPEN AND PUT THE HDD LIKE JUMPER J1 ON AND OFF THE PIN.

still no sign of display.please help.

do i need to connect the phone and laptop and upgrade the firmware.

i donot have  the SPA  IP address and i cannot find it at all.

matiassurdi Wed, 02/24/2010 - 04:03
User Badges:

Same problem also with Linksys SPA922, could you provide us the recovery tool?



Thanks!

ghanibhutto Fri, 10/14/2011 - 08:38
User Badges:

problem with Linksys SPA942, it is in recovery mode, when i started to recovery with

recovery utility message appeared that no SPA found. what should i do now.

dzdelar40 Mon, 07/02/2012 - 14:09
User Badges:

I have the same problem. I cann't run the menu on the phone. I don't know which is the phone IP address.


Any help!

Krabat Wed, 03/26/2014 - 12:21
User Badges:

I Have this problem with spa941 phone. Please give update for recovery my phone

 

Sorry, i found utilites... at bottom of page 

Actions

This Discussion

Related Content