1131AP doesnt join 4402 controller

Unanswered Question
Apr 2nd, 2009

We have 9 1010 AP's which all were just plugged in and auto configured themselves from the controller. We now need another AP so I was told that the 1131 was the replacement model. But I cannot for the life of me get it to be seen by the controller.....

Please help.


I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
paulpoon Thu, 04/02/2009 - 13:37

Are you using DHCP option 43 to give the controller info to the AP?

You can also manually make it join.

Manually Configuring the LAP

In a new installation, when a LAP is unable to find a WLC using the discovery algorithms because DHCP is not enabled on the subnet, you can statically configure the information necessary to join a controller via the console port and the AP's CLI.

Note: The CLI commands in this section can be used on an AP that has never registered to a controller, or on an AP that had its default enable password changed while joined to a previous controller.

In order to manually configure static information on a LAP using the AP CLI interface, you can use these EXEC mode CLI commands:

AP#lwapp ap ip address

AP#lwapp ap ip default-gateway

AP#lwapp ap controller ip address

AP#lwapp ap hostname


Note: You must issue these commands while in enable mode. The default enable password is Cisco.

The static information configured with the CLI commands is used by the AP to join a controller. After joining the controller, the user can configure new settings on the LAP via the controller.


brightwell Fri, 04/03/2009 - 01:34

In the current setup on the access points they dont have an ip address..... is the 1131 different from the 1010 aps?

brightwell Fri, 04/03/2009 - 04:06

Ok, the ap was autonomous not lightweight, so change the firmware and it still does not auto connect to the controller as the 1010's do. So I tried the lwapp commands and the controller and 1131 can ping each other but it is still not addedd to the controller......

What am I missing???



Scott Fella Fri, 04/03/2009 - 05:33

Is your wlc setup for layer 2 mode.... that might be why. Only the 1000 series lap's support the layer 2 mode. You would have to setup the wlc for layer 3, but now your existing ap's will need an ip address.

brightwell Fri, 04/03/2009 - 07:03

I changed the controller to layer 3 and all the exisiting ap's disappeared and did not come back and the 1131 still did not connect, with option 43 or manual settings......

Why hae they changed the way they work...?

Reading further you can only have one device type per ip pool, which is not really a possibility.

Is there no easy way to do this?

paulpoon Fri, 04/03/2009 - 07:10

Where do you see that you can only have one device type per ip pool?

Unless if I am missing something or its something on the newer codes, I have multiple device types on the same ip pools.

brightwell Fri, 04/03/2009 - 07:20

The Cisco IOS DHCP server only allows Option 43 definitions for one device type for each DHCP address pool, so only one AP type can be supported for each DHCP address pool.

cript2000 Fri, 04/03/2009 - 07:52

That DHCP option will work for all the AP models. We use the "c1130" vendor class for 1130s, 1240s, and 1250s.

Scott Fella Fri, 04/03/2009 - 09:36

The best way to do this is to place the ap's in the same subnet as you management and ap-managers. Put a dhcp scope on that subnet and once the ap's get an ip address, they will connect to the wlc. You can then move then to another subnet and don't have to use dhcp option. Make sure that the management and ap-manager vlan is set to native on the switch and also make sure that on the wlc interface for thoses, that is is set to vlan tagging of "0".

Leo Laohoo Fri, 04/03/2009 - 18:37

I strongly agree with Scott (fella5). Cisco recommends that prior to deploying your AP's, it's wise to prime them (connect the AP to the same VLAN subnet to your WLC).

I've been doing this since so it also gives me the opportunity to do an occular inspection of the AP prior to shipment.


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode