database install problem with cucm 7 on vmware

Unanswered Question
Apr 2nd, 2009
User Badges:

Hi,


I use vmare esxi and virtual machine was configured with 2cpu, 2048MB memory, and 80GB hard disk.


CUCM 7 installation failed while running "database installation script". I got "time exceeded error" and system stuck for hours. After rebooted, I was able to ssh in but couldn't do much.


Any idea?


Thanks all,

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
nathanreynolds Fri, 04/03/2009 - 10:47
User Badges:

Hi,

I am having the same issue only on supported hardware (MCS-7835-h1-IPC1). Did you find a fix? Thanks!

smallrain_2 Fri, 04/03/2009 - 12:44
User Badges:

I was able to successfully install that bad boy a few hours ago.


I made only three changes:

1. build a dns server for test lab

2. on vmware NIC was manually set to 100/full (I did notice that after cucm was rebooted during installation, link was bounced. Even though I was able to use vmware client.)

3. Again I am using vmware esxi (free version) on Dell PowerEdge 1800 with two CUP and 2GB Memory. New Virtual Machine was recreated with 1 CPU, 1GB memory and 80GB Hard Disk. Old virtual machine had 2CPU/2GB/80HD setup on failed attempt.

I used same hardware during all installations.


I have my doubt that above changes fixed the problem. But as far as I remembered, those 3 are only changes I made.


Btw, during "database installation script" process, my vm console went dark. But I was able to ssh in and monitor a bit by using command like "utils service list".


Unfortunately, I don't have time to redo antoher installation yet.


Thanks,


nathanreynolds Fri, 04/03/2009 - 13:40
User Badges:

Hey thanks for the reply. I think you are right on with your changes. I think my problem (and yours maybe) was related to DNS. This time around I just chose not to install the DNS client and it worked just fine. Before I was specifying the DNS server(s) that we will have in production, however they were not reachable since all I have connected to the switch is my laptop and the server. My guess is had DNS been reachable the first go round it would have installed fine. Now I should be able to configure DNS and NTP after adding to production and be just fine. Thanks! Nathan

jfrelin Fri, 04/03/2009 - 21:23
User Badges:
  • Cisco Employee,

Greetings -


This issue is caused by two things:


1) DNS failing to reverse resolve

2) Running out of drive space. As best practice, set your VMware images to 80G for consistant results.


I personally don't use DNS during install and you'll get error free installations. Just be patient. Depending on your Host configuration in VM, the installs can take quite some time.


I recommend 4G RAM and 2Ghz+ for semi-normal performance.


-Joe

smallrain_2 Sat, 04/04/2009 - 18:31
User Badges:

Thanks Joe.


I have 2G RAM and it tooke me about 4 hours to complete the installation.

Post installation scripts take forever to finish.


CUCM web admin reponse is very acceptable even with 1G RAM. I haven't tried with heavy load yet though.


Yes. It is very good advice for those who want to try cucm on vmware.


Thanks,

Actions

This Discussion