Phone Designer Error

Unanswered Question
Apr 2nd, 2009

Hi,

I'm trying to use Cisco Phone Designer on my 6.1(2) CUCM Cluster. I did several tests, but the program fails every time with the same error: "An unknown error occurred on your Cisco IP-Phone".

I made a complete check of the config:

- IP-Phone "Phone Personalization" parameter: Enabled

- User associated with the Phone

- Username/Password tested (with ccmuser) successfully

- Phone Firmware: SCCP41.8-4-1SR2S

So I suppose the config is ok.

If I look on the application log files I find this error: 'CiscoIPPhoneError Number="4"'

Is this maybe a bug? Someone of you is using Cisco Phone Designer on CUCM 6.1 successfully?

Thanks for your replies.

Gio

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Jaime Valencia Thu, 04/02/2009 - 09:00

Error 4 is an Authentication Error. Basically, you cannot push content to the IP Phone unless you are authorized to access that phone. This works as designed since we don't want someone just being able to push unsolicited content to any IP phone. Authentication is configured through User Preferences/Associated Devices.

HTH

java

if this helps, please rate

gbonivento Thu, 04/02/2009 - 09:24

Thanks Java for your very rapid reply.

I don't see any authentication problem in my config.

The User I'm using in Cisco Phone Designer is associated with the device I want to customize (User Management -> End Users -> End User Configuration -> Controlled Devices. This seems to be recognized correctly by the program. In fact I performed tests on different Phones (7941, 7961), and Phone Designer displayed each time the correct Phone Layout.

Gio

htluo Thu, 04/02/2009 - 10:45

The login name is case sensitive.

e.g. in CUCM the user ID is JohnDoe. On phone designer, if you log in as 'johndoe' it'll give an error.

Michael

http://htluo.blogspot.com

gbonivento Thu, 04/02/2009 - 23:51

Thanks Michael for your reply.

But as said before I'm 100% sure login credentials are correct.

When you start the Cisco Phone Designer, the program use user/pwd to already logon on CUCM and check which phone is associated with the user). So the fact I get the main program windows is already a confirmation credentials are correctly saved into the program. I also tried to put false user or pwd and in this case I get an error already at the program startup!

gbonivento Fri, 04/17/2009 - 01:09

Java, Michael,

no more ideas/suggestions on that? Already abandoned ;-)

Phone Designer is supported by TAC?

Rgds, Gio.

htluo Fri, 04/17/2009 - 05:20

I would suggest you open a TAC case.

If you'd like to troubleshoot the problem yourself, "Cisco IP Phone Service" log is the one you need.

Michael

gbonivento Mon, 04/20/2009 - 04:58

Ciao Michael,

I've tried to trace the error following your suggestion. Here below the output of the trace during a 'Ring Tone change' test:

009-04-20 14:12:40,250 INFO [http-8443-Processor23] servlet.Personalization - Personalization Servlet doPost invoked !!!

2009-04-20 14:12:40,585 INFO [http-8443-Processor23] servlet.Personalization - XML command from PC (as regular request) :[email protected]

2009-04-20 14:12:40,586 INFO [http-8443-Processor23] pc.RequestHandlerMapper - Forwarding request to ControlledDevices handler

2009-04-20 14:12:40,587 INFO [http-8443-Processor23] log.LoggerTag - ControlledDevices.jsp begins, remote=10.5.231.77, from forwardInfoBean userId=[email protected] password=HiddenPassword xmlCommand=[email protected]

2009-04-20 14:12:40,623 INFO [http-8443-Processor23] log.LoggerTag - ControlledDevices.jsp 10.5.231.77 [email protected] HiddenPassword controls 2 devices

2009-04-20 14:13:04,505 INFO [http-8443-Processor6] servlet.Personalization - Personalization Servlet doPost invoked !!!

2009-04-20 14:13:07,126 INFO [http-8443-Processor6] servlet.Personalization - XML command from PC (as multi-part request) :SEP001819A89B15DesignerRingtone

2009-04-20 14:13:07,164 INFO [http-8443-Processor6] servlet.Personalization - Added device {SEP001819A89B15} to pendingRequests queue

2009-04-20 14:13:07,185 INFO [http-8443-Processor6] servlet.Personalization - saved /usr/local/thirdparty/jakarta-tomcat/webapps/ccmcip/personalizati[email protected]_SEP001819A89B15_tone_DesignerRingtone

2009-04-20 14:13:07,185 INFO [http-8443-Processor6] pc.RequestHandlerMapper - Forwarding request to SetRingTone handler

2009-04-20 14:13:07,186 INFO [http-8443-Processor6] servlet.SetRingTone - servlet.SetRingTone::doPost begins

2009-04-20 14:13:07,409 INFO [http-8443-Processor6] phone.SetRingToneRequest - XML command sent to phone : XML=http://10.6.24.20:[email protected]_SEP001819A89B15_tone_DesignerRingtone

2009-04-20 14:13:07,537 INFO [http-8080-Processor21] log.LoggerTag - authenticate.jsp begins, remote=10.5.231.105

2009-04-20 14:13:07,539 INFO [http-8080-Processor21] log.LoggerTag - Authenticator.jsp included in authenticate.jsp, remote=10.5.231.105, params: UserID= Password=HiddenPassword devicename=SEP001819A89B15

2009-04-20 14:13:07,540 WARN [http-8080-Processor21] log.LoggerTag - Authenticator.jsp ends, remote=10.5.231.105 UN-AUTHORIZED params missing

2009-04-20 14:13:07,622 WARN [http-8443-Processor6] servlet.SetRingTone - Uploaded ring tone file has not been downloaded to phone

2009-04-20 14:13:07,624 INFO [http-8443-Processor6] servlet.SetRingTone - deleted /usr/local/thirdparty/jakarta-tomcat/webapps/ccmcip/personalizati[email protected]_SEP001819A89B15_tone_DesignerRingtone

2009-04-20 14:13:07,625 INFO [http-8443-Processor6] servlet.Personalization - Device used by thread : http-8443-Processor6 current thread : http-8443-Processor6

2009-04-20 14:13:07,626 INFO [http-8443-Processor6] servlet.Personalization - Removed device {SEP001819A89B15} from pendingRequest

As you can see at the beginning Phone Designer program applies correctly user credentials (and discover for example that this user control 2 devices), but then in a second phase, when it tries to send the new ringtone, the UserID parameter is EMPTY

Why?

Do you have still some suggestions for me or you think it's time to open a TAC request?

Thanks again for your help.

Rgds, Gio.

htluo Mon, 04/20/2009 - 06:19

Now we know the problem was user ID empty. The next step is to determine if it's caused by the client or the server.

1) Start a packet capture on the client computer (phone designer).

2) Recreate the problem.

3) Stop the packet capture.

We need the following:

1) Create a problem report from Phone Designer.

2) Cisco IP Phone Services logs

3) Packet capture.

Thanks!

Michael

gbonivento Tue, 04/21/2009 - 09:48

Hi Michael,

First of all, I have difficulties to analyse encrypted traffic between 'Phone Designer' (PD) and CUCM, http-8443 (I'm using wireshark: I need the key used by PD to encrypt traffic, but I don't know how to get it...).

In any case I don't think the problem is between PD and CUCM. The missing UserID params happens between communication between CUCM and IP-Phone (when the CUCM tries to push the new image/ringtone to the phone).

I already verified the 'URL authentication' enterprise parameter of CUCM and it is correct (http://a.b.c.d:8080/ccmcip/authenticate.jsp), where a.b.c.d = IP address of Publisher CUCM.

Rgds, Gio.

nn7963 Fri, 07/09/2010 - 07:49

I fixed the problem on my CCM by going into enterprise parameters and replacing the hostname of the publisher in all of the URLs with the IP address of the Pub.

Actions

This Discussion