Lms3.1 devices failing inventory collection

Unanswered Question
Apr 2nd, 2009

I have some devices suddenly failing inventory collection.

The config archive update is working on the devices, but inventory collection is failing.

Three of the devices (two routers and a switch)are failing with:

RICS0001:Internal Error, unable to process the collected data.

These devices are passing "device credential verification"

The fourth (6509 switch)is just "Device collection Failed"

When I go to "chassis view" it prompts me for credentials and is defaulting to SNMPv3.

I also see in the switch logs:

SSH2 0: Unexpected mesg type received

I have checked the device settings for RME and SNMPv3 is not configured anywhere.

This device is passing "device credential verification" and shows SNMPv3

"no value to test"

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Thu, 04/02/2009 - 10:11

Please post the IC_Server.log after reproducing an inventory collection failure for one of the devices.

wilson_1234_2 Thu, 04/02/2009 - 12:50

Here it is.

It looks like not a whole lot in there.

Update,

It looks like not enough space on disk accroding to the log.

This server has been virtualized and has 11.3 gig on the drive.

Joe, looking at this I see that I may not have posted the log file you are looking for.

the IC_Server.log was created on the 26th and the inventory collection runs every night.

I created a one time job and launched it, but it did not update the IC_Server.;og

wilson_1234_2 Thu, 04/02/2009 - 13:28

I think I have what you are looking for now.

The is from the last inventory I ran and shows the device that is failing

172.16.254.101

Joe Clarke Thu, 04/02/2009 - 14:38

Two problems. For devices 172.16.254.13, 172.16.254.50, and 206.113.198.65, it looks like you're being bit by an old bug which was fixed in RME 4.2. To complete the fix, you need to delete these devices from RME, then re-add them. After that, subsequent inventory collections should work fine.

For device 172.16.254.101, RME is timing out polling the FLASH-MIB. You need to increase the SNMP timeout for this device under RME > Devices > RME Devices > Edit Device Attributes. Set a timeout of 10 seconds for starters.

wilson_1234_2 Thu, 04/02/2009 - 17:17

Thanks Joe,

You have any idea why the last device 172.16.254.101 is suddenly timing out?

It has worked fine every since you helped me get this working about a year and a half ago.

Joe Clarke Thu, 04/02/2009 - 19:24

If you previously increased the timeout, make sure the value is still what it used to be. If the device was upgraded, you may be seeing a device issue where the CISCO-FLASH-MIB takes a long time poll. It could also be a matter of more files on flash causing the device to spin longer building the flash file list.

Actions

This Discussion