Unable to reference FXS port in dial peer statement.

Unanswered Question

I am trying to configure an FXS port on a 3845 rouer. The router sees the FXS and FXO moldules, the "sh inv" displays them.

However when I try to reference the FXS port in the dial peer command the router does not recognise the port number.

I think I may be missing a command at the glaobal level not sure. the attachment displays the output.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Kenneth Mohammed Thu, 04/02/2009 - 10:26


I am assuming that you are using CME. Anyhow, the voice-ports 50/0/1, 50/0/2, etc are not physical ports, they are virtual, and therefore you cannot point any dial-peers to them. In the output of the show voice-port summary, 50/0/1 CH 1 is equal to the first channel of ephone-dn 1 and 50/0/1 CH 2 is equal to the second channel of ephone-dn 1. Im guessing that ephone-dn 1 is configured as dual-line, hence the 2 channels for efxs port 50/0/1.

Pots dial-peers can only be pointed to physical ports. Please post the entire output of show voice-port summary, the ports you need to point your dial-peers to will be marked "fxs-ls" and not "efxs".

Hope that helped, if so please rate.

mattcalderon Thu, 04/02/2009 - 10:49


How are you doing my dear friend? I was thinking the same thing that this is some sort of CME but he did post the "show voice port summary" and the only ports showing seem to be the "virtual" ports although the hardware is listed in the show inventory.


Kenneth Mohammed Thu, 04/02/2009 - 11:43

Whats up Matt,

Im thinking that he didnt post the whole output of show voice port summary.

mattcalderon Thu, 04/02/2009 - 12:11

Could be. Congrats as you recently have been racking up the points and gained a new badge here. You have been busy!


Hi Kenneth,

Yes I am using CME. I was trying to connect some regulat analog phones into the mix. Hence I am using an FXS module to connect these. I was trying to get dial tone on the analog phones from the FXS modules.

The physical FXS and FXO ports don't show up in the config.

I think what you are saying is that the 50/0/1 ports are not the FXO modules I have installed, they are virtual ports not related tot he FXS module I have installed,

Thanks for you your help.


Kenneth Mohammed Thu, 04/02/2009 - 13:11

Hello Andy,

You are correct, the 50/0/x ports are not the cards that you installed. Where are these cards seated. I believe 3845 has slots that are for VIC only (I dont have one in front of me), and it could be possible that you have the cards inserted into the wrong slots. That is the only thing I can think of at this point, as your IOS obviously supports voice since you are running CME.

Hope that helped, if so please rate.

Hello Kenneth,

The FXS and FXS modules are installed int the HWIC slots. See below.

lab-dist8-rtr#sh hardware

Cisco IOS Software, 3800 Software (C3845-IPVOICE_IVS-M), Version 12.4(22)T, RELE


Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Fri 10-Oct-08 07:54 by prod_rel_team

ROM: System Bootstrap, Version 12.3(11r)T2, RELEASE SOFTWARE (fc1)

lab-dist8-rtr uptime is 1 hour, 54 minutes

System returned to ROM by power-on

System image file is "flash:c3845-ipvoice_ivs-mz.124-22.T.bin"

Cisco 3845 (revision 1.0) with 212992K/49152K bytes of memory.

Processor board ID FTX1022A3LU

4 Gigabit Ethernet interfaces

2 Subrate T3/E3 ports

2 Voice FXO interfaces

2 Voice FXS interfaces

When do the command sh voice port summary the modules do not show up. From my reading the 3845 does support the FXO and FXS installed in the HWIC slot.

lab-dist8-rtr#sh voice port summary



=============== == ============ ===== ==== ======== ======== ==

50/0/1 1 efxs up dorm on-hook idle y

50/0/1 2 efxs up dorm on-hook idle y

50/0/2 1 efxs up dorm on-hook idle y

50/0/2 2 efxs up dorm on-hook idle y

50/0/3 1 efxs up up on-hook idle y

50/0/3 2 efxs up up on-hook idle y

thanks foryour help Kenneth I will keep on researching.



This Discussion