DMVPN and IOS to choose

Unanswered Question
Apr 2nd, 2009

Hi,

Just want a recommendation of what IOS I need to use to deploy the DMVPN on Cisco 3845 for Hubs and 2851 for Spokes.

In Cisco web site there is 12.2.33 and 12.4.24 ???

What a better choice 12.2 or 12.4 ?

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Leo Laohoo Thu, 04/02/2009 - 19:27

Hi Tayeb,

If you are trying to avoid bugs then it doesn't matter.

I'd recommend the 12.4 version or later because there are some features that you may want.

Don't forget to upgrade the bootstrap too!

Because you belong to a governement organization that may have strict control on firmware, I would recommend that you check the rest of the routers for IOS uniformity.

Joseph W. Doherty Fri, 04/03/2009 - 05:13

"What a better choice 12.2 or 12.4 ?"

For supported features, later IOS offer more.

For stability, those further in their life cycle might be more stable.

PS:

My understanding had been, mainline software trains, were "frozen" with their first release. All later releases within that version were defect corrections. However, believe that's no longer true for 12.4. For 12.4, instead of simply often using the highest release, you might want to use the highest patch release.

e.g.

12.2(46a) vs. 12.2(29b) and 12.4(23) vs. 12.4(13f)

12.2(46a), in theory (I believe) should only include additional defect patches vs 12.2(29b)

but 12.4(23) might include features not found in 12.4(13f) making it less stable

PPS:

Are you sure about your IOS choices for the 2851 and 3845? I didn't notice a 12.2 release for either the 2851 or 2851.

Leo Laohoo Fri, 04/03/2009 - 18:05

Great catch Joseph! ISR, particularly the 1800, 2800 and 3800 won't run on 12.2 Mainline IOS and you won't be able to find one (I hope I'm not mistaken).

Actions

This Discussion