6506 as a VTP server with extended vlans

Unanswered Question
Apr 2nd, 2009

I'd like to make the 6506 to be as a VTP server

I use only internal vlans for my purposes.

But, when I do:

#vtp mode server

Mode change not allowed. VTP VLAN is in use internally.

Features using internal VLANs in 1..1005 range must first be removed.

Also, I check the internal usage:

#show vlan internal usage

VLAN Usage

---- --------------------

189 GigabitEthernet5/1.189

190 GigabitEthernet5/1.190

1006 online diag vlan0

1007 online diag vlan1

1008 online diag vlan2

1009 online diag vlan3

1010 online diag vlan4

1011 online diag vlan5

1012 PM vlan process (trunk tagging)

1013 Control Plane Protection

1014 GigabitEthernet2/5

1015 vrf_0_vlan0

1016 L3 multicast partial shortcuts for VPN 0

1017 Egress internal vlan

1018 Multicast VPN 0 QOS vlan

1019 IPv6 Multicast Egress multicast

1020 GigabitEthernet1/4

1022 GigabitEthernet5/1

1023 GigabitEthernet1/7

1024 GigabitEthernet5/5

1025 GigabitEthernet5/2

1026 GigabitEthernet1/29

Is it possible to create a VTP server in this situation?

Should I remove all Vlans which are higher than 1005? (and how to do this?)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
andrew.prince@m... Fri, 04/03/2009 - 03:09

Vyacheslav,

VTP does not support extended vlans: 1006- 4096.

If you want to use these vlans - all switches must be put into "transparent" VTP mode.

HTH>

vyacheslav.k Sun, 04/05/2009 - 16:50

Yeah I know it.

And I don't want to use extended vlans.

But as I understand they are used for some services, are not they?

andrew.prince@m... Mon, 04/06/2009 - 00:48

VLANS 1002 to 1005 are no longer used/supported.

Extended VLANS number from 1006-4096 - so anything from 1 to 999 is considered a normal numbered VLAN.

Extended VLANS are not configured in the VLAN Database area or saved in the vlan.dat file in flash. Extended VLANS are part of the device configuration soted in NVRAM.

HTH>

vyacheslav.k Mon, 04/06/2009 - 01:02

Thanks.

But I don't understand where are these VLANS for example:

1014 GigabitEthernet2/5

1020 GigabitEthernet1/4

There are not any lines about them in config files.

andrew.prince@m... Mon, 04/06/2009 - 01:08

Those vlans will not be propagated via VTP - so they will have to have been configured manually by someone.

You need to check all your switches to see if any layer 2 ports are actually assigned to those vlans - if not then remove them.

HTH>

vyacheslav.k Mon, 04/06/2009 - 01:14

Yeah I know about VTP. And about 1-999 vlans.

I use only 1-999 vlans in my network, so I don't need extended Vlans. Moreover, I did not configure them at all.

So, how to remove extended vlans if there are not any lines about them in config files ?

andrew.prince@m... Mon, 04/06/2009 - 01:28

remove them from the config from configuration mode:-

conf t

no vlan xxxx = xxxx is the number you want to remove.

HTH>

vyacheslav.k Mon, 04/06/2009 - 18:22

It does not work.

For example, I do:

show vlan internal usage | in 1026

1026 GigabitEthernet1/29

sh run int g1/29

Building configuration...

Current configuration : 52 bytes

!

interface GigabitEthernet1/29

no ip address

end

Then I do:

(config)#no vlan 1026

Then I check again this vlan:

1026 GigabitEthernet1/29

It exists!!

Maybe there is another way to remove it ?

andrew.prince@m... Tue, 04/07/2009 - 01:30

OK - well that means on the switch you issued the command, no interface either up/up or down/down or admin down/down is configured into vlan 1026.

Post the output of "show vlan"

mike.harlow Tue, 04/07/2009 - 04:35

Try setting the port in question to layer 2 ("switchport"), the internal vlans are created for L3 ports. This will possibly remove the high numbered internal vlans.

However, if you read the error it is complaining about vlans in the 1-1005 range. I suspect it does not like the sub-interfaces you have. I'd remove the two sub interfaces on that gig port, then go to server mode, then put the sub interfaces back on.

vyacheslav.k Tue, 04/07/2009 - 16:52

VLAN Name Status Ports

---- -------------------------------- --------- -------------------------------

1 default active Gi3/1, Gi3/2

.........................

.........................

800 v800 active

839 v839 active

899 v899 active

1002 fddi-default act/unsup

1003 trcrf-default act/unsup

1004 fddinet-default act/unsup

1005 trbrf-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------

1 enet 100001 1500 - - - - - 0 0

.........................

.........................

800 enet 100800 1500 - - - - - 0 0

839 enet 100839 1500 - - - - - 0 0

899 enet 100899 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 trcrf 101003 4472 1005 3276 - - srb 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trbrf 101005 4472 - - 15 ibm - 0 0

VLAN AREHops STEHops Backup CRF

---- ------- ------- ----------

1003 7 7 off

Remote SPAN VLANs

------------------------------------------------------------------------------

Primary Secondary Type Ports

------- --------- ----------------- ------------------------------------------

C6506#

That's all.

andrew.prince@m... Wed, 04/08/2009 - 01:00

The above clearly indicates that you have NO switch ports in ANY extended VLAN's and that the device has NO extended VLAN's configured at all.

HTH>

vyacheslav.k Wed, 04/08/2009 - 16:54

I wrote about the same several posts before.

So, how to make a VTP server in this way?

The command:

#show vlan internal usage

VLAN Usage

---- --------------------

189 GigabitEthernet5/1.189

190 GigabitEthernet5/1.190

1006 online diag vlan0

1007 online diag vlan1

1008 online diag vlan2

1009 online diag vlan3

1010 online diag vlan4

1011 online diag vlan5

1012 PM vlan process (trunk tagging)

1013 Control Plane Protection

1014 GigabitEthernet2/5

1015 vrf_0_vlan0

1016 L3 multicast partial shortcuts for VPN 0

1017 Egress internal vlan

1018 Multicast VPN 0 QOS vlan

1019 IPv6 Multicast Egress multicast

1020 GigabitEthernet1/4

1022 GigabitEthernet5/1

1023 GigabitEthernet1/7

1024 GigabitEthernet5/5

1025 GigabitEthernet5/2

1026 GigabitEthernet1/29

In summary, I have NO and ports with Extended vlans but I have some extended vlans at this time.

Moreover, the command:

#vtp mode server

Mode change not allowed. VTP VLAN is in use internally.

Features using internal VLANs in 1..1005 range must first be removed.

Is it a bug ?

How to remove extended vlans which there are not exist in the config file ?

vyacheslav.k Thu, 04/09/2009 - 01:20

So, there are not any extended vlans at my 6506.

But:

#vtp mode server

Mode change not allowed. VTP VLAN is in use internally.

Features using internal VLANs in 1..1005 range must first be removed.

How to enable a VTP server in this way ?

andrew.prince@m... Thu, 04/09/2009 - 01:59

Have you tried in config mode?

Have you tried to add it in the vlan database

post the output of "sho vtp stat!

John Fredrik Ølstørn Mon, 08/10/2009 - 04:40

Hi.

I have exactly the same issue as you. Did you test Mikes suggestion about deleting the sub-interfaces, change to server-mode and then reinstall the sub-interfaces? I can not try this in production and would reaaly appreciate a hint if this solved your problem.

vyacheslav.k Mon, 08/10/2009 - 23:49

Hi.

Unfortunately, this did not resolve the problem.

In addition, after I had some discussions with other people working with Cisco, I decided not to use VTP at all.

Wassim Aouadi Sat, 07/03/2010 - 09:18

allow me to correct something:

the normal vlan range is 1 - 1005;

the extended vlan range is 1006 - 4094 and not 4096. Vlan 4095 is reserved for system use only.

my 2 c

Actions

This Discussion