Phone Status in CUPS 7.0(2)

Unanswered Question
Apr 2nd, 2009

Hi,

We are using CUCM 6.1(2) wirh CUPS 7.0(2) without LDAP integration. We don't use CUPC, we have do integrate Sametime-Connect client 8.0.

Our Problems:

First we see no Line association on CUPS Presence Viewer, but have done alls integration-steps (Owner, Device-Association, Line-Config..)

Second our Sametime-Connect-Client has login sucessfully on CUPS but have troubles with sip-registration on tcp 5060.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
htluo Fri, 04/03/2009 - 05:47

The best practice for Sametime/CUPS integration is to use CUPC as a test tool.


The Cisco plugin in Sametime-connect-client is like a "mini-CUPC". But the troubleshooting info and logs are as detailed as CUPC.


If you can get CUPC worked, troubleshooting Sametime plugin would be much easier.


To answser you questions:


1) "Line Assoication" was configured at CUCM Admin > Device > Phone > Directory Number > (bottom of the page) Associate to End User.


2) To fix "SIP registration" issue, try to go to CUPS Admin > System > Security > Incoming ACL. Add an ACL with address pattern "all" (without quotations).


For more tech tips, see http://htluo.blogspot.com


Thanks!

Michael

htluo Fri, 04/03/2009 - 08:05

If I understood it right, you were NOT able to see phone presence on CUPC. Is that correct?


If yes, you need to troubleshoot phone presence on CUPC first.


There are many stuff to check on this:

1) SIP trunk between CUPS and CUCM

2) Line appearance association

3) CUP licensing

4) CUPC reachability status


It's very difficult to troubleshoot phone presence issue from CUPC log. Because CUPC passively receive the phone presence info. It won't complain if it didn't receive phone presence (ie. no error messages in CUPC logs).


I'd recommend you open a TAC case or take a look at http://www.lulu.com/content/5552336.


Thanks!

Michael

martin1.plank Fri, 04/03/2009 - 08:13

Hi,


Yes, you unterstood it right!!

Your book is already ordered!

At monday we'll do a new server installation for CUPS. For CUCM we'll delete all configurations.

Do you have a giudeline for the installation we need? CUPS 7.0(2) and CUCM 6.1(2) without LDAP.


Thanx for your help so far! Nice weekend!

martin1.plank Wed, 04/29/2009 - 03:28

Hi!

Now we got the book "Deploying Cisco Unified Presence" but we've still problems.

First: Our "Client status" didn't work properly. In step 2 we have to create a Proxy Profile and assign users to it. Sorry but in CUPC7.0 i cant's find that option??

martin1.plank Wed, 04/29/2009 - 04:36

I've now found my BUG. It was a problem with auf FW-System. Can anyone tell me the TCP port range for "Livebus messaging port"? At doku cupsportusage.pdf only 50000 is in use, but we are using a range!

htluo Wed, 04/29/2009 - 04:38

On CUPS 7, you don't have to create a proxy profile. All users will be put in a system default profile.


What problem you are having now?


Michael

martin1.plank Wed, 04/29/2009 - 04:44

Now i see client status available and so on, but on "General" i won't see my own User (contact)! I think CUPC didn't receive "200" in SIP.

vinhnguyen Thu, 06/17/2010 - 17:59

Hi


Could you send me a screen capture of sametime client with phone status icon.  Does the phone appears by default after we install the plugin (but greyed out) or does it come on only after we integrate CUPS with sametime?  Does the new version of CUPS 7.0(2) look at other ldap field like description rather than the internet address?


Thanks

martin1.plank Tue, 07/13/2010 - 12:35

Since my last update I did a

lot of things!


Now we use the last available Cisco Click-to-dial Plugin. We also use LDAP for user an user-authentication.

We use CUCM 6.1.4 and CUPS V7.

For LDAP we had to use a TLS connection, but the plugin doesn't support TLS.

With CUPC Presence works but for Sametime I can't see the icons for presence at the samtime frontend.

abdel-moniem Tue, 12/28/2010 - 09:53

HI Martin

I am facing the Same issue with Sametime Connect Plugin , I have 8.0.1 B with LN 8.0 and sametime connect 8.0 and 8.5.1 ( two pcs ) . CUCM version 7.1.5 . CUPS 7.0

The phone icon is not displayed beside the user reflect his presence information ( offhock , on hock...etc )

I have tried using CUPC as a test and it works fine without a problem .

Did you reach somthing in ur issue

thanks

Actions

This Discussion