Cisco 6509 WCCP L2

Unanswered Question
Apr 3rd, 2009
User Badges:

Cisco 6509 WCCP L2, Can someone please tell me what the minimum software requirements are to run L2 forward & return on a IOS based 6509 w Sup720's.

I currently run SXE code and cannot get the L2 to work.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dstolt Fri, 04/03/2009 - 09:09
User Badges:
  • Cisco Employee,

Jeff,


For current implementations of WCCP for L2 forwarding and IP Forwarding (WAAS and ACNS clients), I usually recommend SXF13 or later.


If you are using a Sup32/720 and require L2 return (depending on your WCCP client wether is supports it or not), then you have to look at the newer code for the 6500, which support L2 return in hardware. This is introduced in SXH and also supported in SXI. The exception to this would be if you are using a Sup2, and then it's supported in SXF train, where I still recommend SXF13 or later.


Hope that helps,

Dan



Mark Yeates Fri, 04/03/2009 - 09:11
User Badges:
  • Gold, 750 points or more

Jeff,


If I remember correctly you will need the 12.2(33)SXH (or later) IOS for L2 forward & return support. I know that there were many WCCP enhancements with the SHX releases.


HTH,

Mark

David Niemann Wed, 07/28/2010 - 12:09
User Badges:

I know this is kind of old, but I am having trouble getting this to work with L2 on 12.2(33)SXI3.  I'm using the config below and only sending one host to the proxy for testing.  VLAN 100 is the VLAN connects the internal LAN to the FWSM and VLAN 3 is dedicated to proxys, both are the same VRF to allow the MSFC to route behind the firewall without bypassing it. Anything wrong with my router config?


From the 6509


ip wccp 10 redirect-list WCCPRedirect group-list ProxyPermit2WCCPGroup password 7 accelerated

!

interface Vlan100
ip vrf forwarding TrustedNet
ip address 10.1.0.6 255.255.255.192
no ip redirects
no ip unreachables
no ip proxy-arp
ip wccp 10 redirect out
ip ospf authentication message-digest
ip ospf message-digest-key 1 md5 7
ntp broadcast client
ntp broadcast
standby 0 ip 10.1.0.1
standby 0 preempt

!

interface Vlan3
description Proxy net
ip vrf forwarding TrustedNet
ip address 10.0.0.50 255.255.255.240
no ip redirects
no ip unreachables
no ip proxy-arp
ntp broadcast client
ntp broadcast
standby 0 ip 10.0.0.49
standby 0 preempt

!

ip access-list standard ProxyPermit2WCCPGroup

permit 10.0.0.54

!

ip access-list extended WCCPRedirect

permit tcp host 10.1.0.200 any eq www

!

Actions

This Discussion