QoS Help Please on 2811 with NM-16ESW

Unanswered Question
Apr 3rd, 2009

We're using Cisco 2811's at branch sites. I need help with the QoS configuration on the Fast0/0 interface and also for the NM-16ESW. We're testing on a cable modem connection (yes I know this is not optimal) with 6 Mbps download and 512 Mbps upload. All works great except for when I stress test the WAN link.

I have the following config for Fast 0/0:

class-map match-any QoS-VoIP-RTP-Trust

match protocol rtp audio

match access-group name QoS-VoIP-RTCP

class-map match-any QoS-VoIP-Control-Trust

match access-group name QoS-VoIP-Control

!

!

policy-map QoS-Policy-Trust

class QoS-VoIP-RTP-Trust

priority 128

class QoS-VoIP-Control-Trust

bandwidth 64

class class-default

fair-queue

interface FastEthernet0/0

description Road Runner Cable Modem

ip address dhcp

ip nat outside

ip virtual-reassembly

load-interval 30

duplex auto

speed auto

crypto map 3DESmap

service-policy output QoS-Policy-Trust

ip access-list extended QoS-VoIP-Control

permit tcp any any eq 1720

permit tcp any any range 11000 11999

permit udp any any eq 2427

permit tcp any any eq 2428

permit tcp any any range 2000 2002

permit udp any any eq 1719

permit udp any any eq 5060

ip access-list extended QoS-VoIP-RTCP

permit udp any any range 16384 32767

No packets voice packets are being classified as voice:

XXX-2811#show policy-map interface fastEthernet 0/0

FastEthernet0/0

Service-policy output: QoS-Policy-Trust

queue stats for all priority classes:

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

Class-map: QoS-VoIP-RTP-Trust (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: protocol rtp audio

0 packets, 0 bytes

30 second rate 0 bps

Match: access-group name QoS-VoIP-RTCP

0 packets, 0 bytes

30 second rate 0 bps

Priority: 128 kbps, burst bytes 3200, b/w exceed drops: 0

Class-map: QoS-VoIP-Control-Trust (match-any)

0 packets, 0 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: access-group name QoS-VoIP-Control

0 packets, 0 bytes

30 second rate 0 bps

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops) 0/0/0

(pkts output/bytes output) 0/0

bandwidth 64 kbps

Class-map: class-default (match-any)

9354 packets, 1393816 bytes

30 second offered rate 0 bps, drop rate 0 bps

Match: any

Queueing

queue limit 64 packets

(queue depth/total drops/no-buffer drops/flowdrops) 0/0/0/0

(pkts output/bytes output) 9354/1394362

Fair-queue: per-flow queue limit 16

On the NM-16ESW ports I have the following configured for all ports:

interface FastEthernet1/0

switchport voice vlan 2

load-interval 30

mls qos trust cos

-----------------

Can someone please help me with both the QoS config for Fast0/0 (the WAN interface) and also for the NM-16ESW interfaces? Can we also police the inbound interface to ensure some room is left for voice packets? Can you provide an example?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jordan.bean Fri, 04/03/2009 - 11:08

I think I have this figured out. Things appear to be working under load:

class-map match-all voice-signaling

match dscp af31

class-map match-all voice-traffic

match dscp ef

!

!

policy-map qos-voice-child

class voice-traffic

priority 66

class voice-signaling

bandwidth 32

class class-default

fair-queue

policy-map qos-voice

class class-default

shape average 512000

service-policy qos-voice-child

interface FastEthernet0/0

description Road Runner Cable Modem

ip address dhcp

ip nat outside

ip virtual-reassembly

rate-limit input 4496000 32000 32000 conform-action transmit exceed-action drop

load-interval 30

duplex auto

speed auto

crypto map 3DESmap

service-policy output qos-voice

I'm using a parent/child policy map to first shape for the 512kbps outbound. I then prioritize the voice/signalling traffic. This seems to be working.

On the outbound, I just set a rate-limit to ensure that there is always bandwidth available for voice traffic. Any other suggestions for this so I can take advantage of the unused bandwidth?

slotking22 Wed, 01/13/2010 - 18:18

hi,

I am trying to get 2600 I just purchase to connect to road runner with DHCP!

but I am not having any luck!!!

I posted it here, because you seem to have it working

I even tried to hook it to my wireless router to see if the port would pull an IP address.

the interface config is

interface FastEthernet0/0
description internet
ip address dhcp
ip accounting output-packets
ip nat outside
no ip route-cache cef
no ip route-cache
duplex auto
speed auto
no cdp enable

I do have DHCP server enabled on the router to hand out dhcp on the lan side and that does work

slotking22 Sun, 01/17/2010 - 14:36

also found this:

If I remove the last option (option 52) from the emulated dhcp discovery packet the cable modem successfully answer the cisco request with a dhcp offer. Further actions like answering to the dhcp offer are beyond the scope of my test and no further actions were taken by the emulation program.

Conclusions:
»www.cisco.com/en/US/docs/net_mgm···Opts.pdf

Option 52 is used by DHCP as an additional space in case the server needs to send back additional data to the client. For some reason the cable modem is not answering the cisco request if this option is present.

Actions

This Discussion