Invalid CSR using "enroll with entrust" in ASDM 6.1 on ASA running 8.0 (2)

Unanswered Question

Hello,

I am trying to install a SSL certificate on my ASA 5505 prior to configuring the anyconnect client.

I tried doing it by following the documentation here:

http://cisco.com/en/US/products/ps6120/products_configuration_example09186a00808b3cff.shtml

I tried in ASDM and using the CLI without success.

Entrust suggested I use the "enroll with entrust" button in ASDM. I upgraded my ASDM image to get this new feature.

Whatever I try, I always get an invalid CSR. The CSR doesn't follow the format

-----BEGIN CERTIFICATE REQUEST-----

/*encoded hash data */

-----END CERTIFICATE REQUEST-----

Even if I add it to the CSR, it still doesn't work.

When I submit it to entrust, I can see my FQDN, CA, C, O and St options...

I'm out of ideas...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
vmoopeung Thu, 04/09/2009 - 13:03

If the certificate you select is configured for manual enrollment, you should obtain the CA certificate manually and import it here. If the certificate you select is configured for automatic enrollment, the security appliance uses the SCEP protocol to contact the CA, and then automatically obtains and installs the certificate.

http://www.cisco.com/en/US/docs/security/asdm/6_1/user/guide/certs.html#wp1300243

Actions

This Discussion