Filtering EIGRP Redistributed Static Routes

Unanswered Question
Apr 3rd, 2009
User Badges:

I want to filter a redistributed static host route - /32 from being advertised through EIGRP to a neighboring router.


If I create an acces-list like this:

access-list 10 deny 10.l.1.1 0.0.0.0

access-list 10 permit any


Here is the static route:

ip route 10.1.1.1 255.255.255.255 10.2.1.1

ip route 10.2.1.1 255.255.255.0 10.20.100.0


Here is the routing proto:

router eigrp 1

redistribute static

distribute-list 10 out static


Only the 10.1.1.1 host route is filtered....and the second /24 gets through? Do distribute-lists normally filter redistributed static routes or just the networks listed under EIGRP?


Thank you!



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
lamav Fri, 04/03/2009 - 13:23
User Badges:
  • Blue, 1500 points or more

Personally, I like using a route map attached to the redistribute statement.


route-map REDIS.STATIC deny 10

match ip address 10


route-map REDIS.STATIC permit 20



access-list 10 permit 10.1.1.1


router eigrp 1

redistribute static metric 1000000 10 255 1 1500 route-map REDIS.STATIC


ip route 10.1.1.1 255.255.255.255 10.2.1.1

ip route 10.2.1.1 255.255.255.0 10.20.100.0


10.1.1.1 gets redistributed, 10.2.1.1 does not.


HTH


Victor

royalblues Fri, 04/03/2009 - 14:24
User Badges:
  • Green, 3000 points or more

It actually depends on the configuration


For eg..

distribute-list 10 out static will restrict the static routes to be redistributed (if redistribute static is configured) It still advertises the Prefixes that are learnt as a result of turning on EIGRP using network statements


on the other hand distribute-list 10 out will filter out everything being advertised from every interface


eg.. R1(e0/1) -- e0/0(R2)

R1

router eigrp 1

redistribute static

network 1.0.0.0

network 2.0.0.0

network 20.0.0.0

distribute-list 1 out static

distribute-list 1 out Ethernet0/0

no auto-summary

!

ip http server

ip classless

ip route 3.3.3.0 255.255.255.0 10.10.10.1


access-list 1 permit 1.1.1.1


r2

r2#sh ip route

Gateway of last resort is not set


1.0.0.0/24 is subnetted, 1 subnets

D 1.1.1.0 [90/409600] via 20.20.20.1, 00:01:50, Ethernet0/0

2.0.0.0/24 is subnetted, 1 subnets

D 2.2.2.0 [90/409600] via 20.20.20.1, 00:01:50, Ethernet0/0

20.0.0.0/24 is subnetted, 1 subnets

C 20.20.20.0 is directly connected, Ethernet0/0

r2#


As you see, eventhough the distribute-list is configured since it has a static keyword, only that prefix gets filtered.


Narayan


myounger Fri, 04/03/2009 - 14:43
User Badges:

I tried filtering 6 static routes last night using an access-list, but did not use the "static" keyword and it did not appear to work. The neighbor router never dropped the route.Since this is a third-party managed router I could not clear the eigrp neighbor or route table to make it refresh. How long does it hold on to an advertised route and then drop based on not receiving it. My static routes were not listed under the EIGRP routing process. Did I not wait long enough for the route to drop out. I know my access-list was correct.

royalblues Fri, 04/03/2009 - 14:49
User Badges:
  • Green, 3000 points or more

Actually the moment you change the configuration of the distribute-list, the router would send a good bye message and reestablish the adjacency so it is almost immediate


If you want to advertise only a set of static routes, you can use a route-map directly with redistribution as suggested by Victor


Narayan

lamav Fri, 04/03/2009 - 15:01
User Badges:
  • Blue, 1500 points or more

You also didnt establish a seed metric in your config from last night.


Thats probably why it didnt work.


Did you notice that I added that?

Actions

This Discussion