ISIS/CLNS routing weirdness?

Unanswered Question
Apr 3rd, 2009

I have just begun experimenting with ISIS and CLNS. Routers F, G, and H are on a multiaccess segment. I have enabled ISIS on all of them and configured "clns router isis" on their broadcast interfaces. They are all level-1-2 routers at the moment.

For kicks and giggles, I configured an additional NET on Router G. (CLNS- and ISIS-relevant configs are in the next post...)

All routers are in area 49.0100; G's extra NET puts it in area 49.0200 as well. What confuses me is that the output of "show clns route", on each machine, lists 49.0200 learned through IS-IS and 'via' themselves; rather than via Router G (which, as best I can tell, is the only router that actually links to area 49.0200).

Why do the routers believe they can get to G's area "via [themselves]?"

Here's the output of sh clns route on each:

=============================================

Router-F>sh clns route

Codes: C - connected, S - static, d - DecnetIV

I - ISO-IGRP, i - IS-IS, e - ES-IS

C 49.0100 [2/0], Local IS-IS Area

C 49.0100.6001.6002.6003.00 [1/0], Local IS-IS NET

i 49 [110/10]

via Router-H, TokenRing0

i 49.0200 [110/0]

via Router-F

Router-F>

=============================================

Router-G>sh clns route

Codes: C - connected, S - static, d - DecnetIV

I - ISO-IGRP, i - IS-IS, e - ES-IS

C 49.0100 [2/0], Local IS-IS Area

C 49.0200 [2/0], Local IS-IS Area

C 49.0200.0009.2234.5432.00 [1/0], Local IS-IS NET

C 49.0100.0009.2234.5432.00 [1/0], Local IS-IS NET

i 49 [110/10]

via Router-H, TokenRing0

Router-G>

=============================================

Router-H>sh clns route

Codes: C - connected, S - static, d - DecnetIV

I - ISO-IGRP, i - IS-IS, e - ES-IS

C 49 [2/0], Local IS-IS Area

C 49.0100.08de.5cab.00 [1/0], Local IS-IS NET

i 49.0100 [110/0]

via Router-G, TokenRing0

via Router-H

i 49.0200 [110/0]

via Router-H

Router-H>

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
CriscoSystems Fri, 04/03/2009 - 17:54

=============================================

Router F config

!

clns routing

!

interface TokenRing0

ip address 10.4.4.6 255.255.255.0

ip router isis

ring-speed 16

clns router isis

!

router isis

net 49.0100.6001.6002.6003.00

=============================================

Router G config

!

clns routing

!

interface Serial0

ip address 215.0.0.13 255.255.255.252

encapsulation ppp

no ip mroute-cache

no fair-queue

clockrate 1000000

clns router isis

!

interface Serial1

no ip address

encapsulation ppp

!

interface TokenRing0

ip address 10.4.4.7 255.255.255.0

ip router isis

ip policy route-map word

ring-speed 16

clns router isis

!

router isis

net 49.0100.0009.2234.5432.00

net 49.0200.0009.2234.5432.00

!

=============================================

Router-H

!

clns routing

!

interface TokenRing0

ip address 10.4.4.8 255.255.255.0

ip router isis

clns router isis

!

router isis

net 49.0100.08de.5cab.00

!

Giuseppe Larosa Sun, 04/05/2009 - 03:35

Hello Stuey,

my only note here is the following:

the type of configuration you have implemented on Router G is supported for migration purposes: up to three net are supported to make easier the process of migration from a CLNS address plan involving area1 to another address plan involving area2.

CLNS just needs one address /net for a node whatever is the number of physical interfaces running CLNS, IPv4 and IPv6 uses one or more prefixes for each L3 interface.

This is a big difference and makes the results of sh clns route different and sometimes difficult to be read.

Notice that for an area of which a node is a member of you can get a list of IS intermediate systems connected to the area and known via the flooding of their respective LSPs.

In the case you show the router is probably telling in its own way that to reach the other area it needs some form of recursion through the area it is a member of.

A different scenario is when you use multiple IS-IS processes and each has its own net.

see

http://www.cisco.com/en/US/docs/ios/isoclns/configuration/guide/configure_iso_clns_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1071447

Hope to help

Giuseppe

Actions

This Discussion