Need help with 3825 QOS config

Answered Question

I just installed a new 3825 for our internet router. Very happy with it.

However now I need to reserver a certain amount of bandwidth for outbound video conference connections. We currently have a 70Mbps connection. Our average utilization is 30 percent on a busy day.

However it is possible for 1 or 2 people to saturate the link pending downloads.

How do I reserve 5 Mbps of bandwidth just for the video conference connections ? I would hate the VP's to try a vid call out and not have it work optimally b/c someone was downloading the newest version of linux and saturating the link.

Any help would be appreciated.


Cheers

Dave

Correct Answer by Joseph W. Doherty about 8 years 1 month ago

policy-map testpol1

class test_class1

bandwidth 5000

shape average 5000000


policy-map main_pol1

class class-default

shape average 20000000

service-policy testpol1


NB: The above might not be accepted, if not, you could try:


policy-map main_pol1


class test_class1

bandwidth 5000

shape average 5000000


class class-default

shape average 15000000


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (4 ratings)
Loading.
Marwan ALshawi Sat, 04/04/2009 - 18:25
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

Hi Dave

you can do it ofcourse

but there is things you need to consider wen you do QOS

now how the router will know this traffic is your video or it is not ?


the answer is there is many ways to know it this is called clasifications


if you have cisco switches and your video has some sort of L2 or L3 marking you can mark and trust that QOS marking from the switches and then reserve that amount of bandwidth in the router in terface


i wil lassum you dont have experience with this stage and you only concerned about the bandwidth reservation on the router outbound interface


in this case we need to clisify the traffic in the router it self


lets say you video use IP address 10.1.1.1

ok ( if it use range use that range same idea)


lets match that traffic from that endpoint first


access-list 100 permit ip host 10.1.1.1 any


class-map video-calss

match access-group 100


policy-map video-policy

class video-calss

bamdwidth 50000


now here i will do it for in way called nest QOS we will shape the overall interface bandwith to 70M and we will use the above policy under it


now this is to shape oveall interface bandwidth this will help you to have som sort of buffer


policy-map main-policy

class class-default

shape avrrage 70000000

service-policy video-policy


now lets apply it to the interface

dont forget to make the interface bandwidth as 70 Mb this way the policy will com to the effect when the 70 M is conjested


interface Fa0/0

bandwith 70000

service-policy output main-policy


this should be to output interface to WAN or internet or whatever outside connection u use

above is one way i think simple way for you there is alot of ways to achieve the same


good luck

if helpful Rate

Great reply and explanation, thanks alot. I know all of my outbound video traffic will be coming from one public IP so I should be able to match that fine. I noticed your policy-map restricted the bandwidth to 50000, but if I read right it should be 5000 for 5Mbps correct ?

I'll test this in the lab tonight.


Cheers


Dave

Joseph W. Doherty Sun, 04/05/2009 - 08:29
User Badges:
  • Super Bronze, 10000 points or more

Some additional notes to what Marwan suggested.


When shaping for Ethernet, you might want to account for Ethernet framing overhead. I.e. shape 10% to 15% slower than "nomimal" bandwidth.


On many platforms (pre 12.4.20T), class-default defaults to WFQ which competes against defined class flows. To avoid this, configure the class-default to FIFO.


PS:

If your average utilization is a low as you note, you might not need to define a sub-policy because GTS shaping, itself, uses WFQ (again on many platforms, pre 12.4.20T).


PPS:

"someone was downloading the newest version of linux and saturating the link. "


Downloading would be saturation inbound? If so, different (harder) problem.

So I am trying this in the lab right now on a test 2651XM router. Here is the config. Essentially I have 4 laptops, 2 on each side of the router. I have set the shape average to 20Mbps for the link as well as the bandwidth for the interface. The 2 laptops in 192.168.10.0 subnet are both copying a 700MB file to each of the laptops across the router.

So laptop (10.3) starts the copy and max's out the 20Mbps. Then laptop (10.2) starts its copy and I should see its bandwidth limited to 5Mpbs, but it actually ramps up to 12Mbps. So it doesnt see to be limiting it 5Mbps. Any thoughts ?



Building configuration...


Current configuration : 1129 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname test1

!

boot-start-marker

boot-end-marker

!

enable secret 5 $1$tfdP$A4sL2IBIRs62BRaJgwvGv0

!

no aaa new-model

no network-clock-participate slot 1

no network-clock-participate wic 0

ip cef


multilink bundle-name authenticated


archive

log config

hidekeys

!

!

!

class-map match-all test_class1

match access-group 101

!

!

policy-map testpol1

class test_class1

bandwidth 5000

policy-map main_pol1

class class-default

shape average 20000000

service-policy testpol1

!

interface FastEthernet0/0

ip address 192.168.10.1 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet0/1

bandwidth 20000

ip address 192.168.20.1 255.255.255.0

duplex auto

speed auto

service-policy output main_pol1

!

ip forward-protocol nd

!

ip http server

!

access-list 101 permit ip host 192.168.10.2 host 192.168.20.3

snmp-server community test RW

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password test

login

!

!

end

Joseph W. Doherty Sun, 04/05/2009 - 17:51
User Badges:
  • Super Bronze, 10000 points or more

Test_class1 isn't limited to 5 Mbps. Bandwidth statement within a class policy defines a minimum, not a maximum.

Correct Answer
Joseph W. Doherty Sun, 04/05/2009 - 18:49
User Badges:
  • Super Bronze, 10000 points or more

policy-map testpol1

class test_class1

bandwidth 5000

shape average 5000000


policy-map main_pol1

class class-default

shape average 20000000

service-policy testpol1


NB: The above might not be accepted, if not, you could try:


policy-map main_pol1


class test_class1

bandwidth 5000

shape average 5000000


class class-default

shape average 15000000


Joseph W. Doherty Mon, 04/06/2009 - 04:08
User Badges:
  • Super Bronze, 10000 points or more

Great!


I wasn't sure about the first config (i.e. nested shapers) would be acceptable to the router. (It might work with 12.4.20T or later QoS.)


Do keep in mind, the disadvantage of the 2nd approach, it also limits all other traffic to 15 Mbps, even if the other 5 Mbps is available. (Sometimes we're forced into a less than optimal QoS model yet one that provides the service guarantees we require.)

Marwan ALshawi Mon, 04/06/2009 - 04:22
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

i think both of them works fine

but why with the next one u have given the other traffic 15Mb what about the other 5M

is it becuase of the MAX bandwidth that can be allocated is 75% of the interface ?

and this come to effect after we put the bandwith command under the interface ?


thank you


Marwan ALshawi Mon, 04/06/2009 - 14:24
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

sorry guys

i asked because i thought you talking about the ogiginal question while you talking about the lab example


i think in this case the example 2 wil work


as you need in total only 20M



Marwan ALshawi Tue, 04/07/2009 - 00:36
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi Joseph

i am wonderring here we given the interface bandwidth as 20M

and th epolicy used in the shper GTS 20M

why we didnt got error becuase by default the interface should le us to use 75% of the interface bandwidth

and we can chamge it by the commad max-reserved


any idea ?

Joseph W. Doherty Tue, 04/07/2009 - 03:08
User Badges:
  • Super Bronze, 10000 points or more

Marwan, I suspect the problem with the one suggested hiearchal policy was due to nested shapers, not anything with max-reserve. In that example, the child policy defined 5 Mbps (25%) of parent's 20 Mbps bandwidth. If it had tried to define more than 15 Mbps (75%) than the default for max-reserve could be an issue. Further, believe the max-reserve would only apply to the bandwidth statement, not the shaper.

Actions

This Discussion