Inter-VLAN communication

Unanswered Question
Apr 4th, 2009

Hello everyone,

I have a Cisco Catalyst 4507R (core switch), I want to implement inter-VLAN communication within my 5 subnet (ex: vlan 12, vlan 17, vlan 20 etc). Can you please guide me on the exact configuration on how to do this. Any help will be greatly appreciated.

--chie

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Marwan ALshawi Sat, 04/04/2009 - 22:53

ok

first of all you need to know there will be tow type of communication here L2 within the same Vlan and L3 from one vlan to other

now lets say u have access switches connected thorugh uplinks trunk ports to your 4507

make the 4507 as VTP server and the access switches as VTP client in the same domain

creat the L2 vlans first in the 4507

for example

vlan 12,17,20 [hit enter]

this will creat the L2 vlans

now in the 4507 creat three L3 SVIs aslo know as switch virtual interface this interface is a vlan interface that will be the default-gateway to all hosts in that vlan

for example

interface vlan 12

ip address 10.1.12.1 255.255.255.0

no shut

interface vlan 20

ip address 10.1.20.1 255.255.255.0

also make sure you put the command

ip routing

on the 4507

now in the access switches assign ports to what ever vlan of those u have created

and make each host default-gateway as the ip address of the corsponding vlan interface

in our example here hosts in vlan 20 must have thier default gatewa as 10.120.1

now this wil give you the abilty to route between vlans

if you have other switch connected with your 4507 thorugh L3 link and has other vlans that you want to route with in the case you need to run a routing protocol such as EIGRP

good luck

if helpful Rate

lazon Sun, 04/05/2009 - 04:12

marwanshawi,

First of all, thank you for the quick response. Is it possible not to run VTP domain and client and just create the correponding VLAN's. I know that ip CEF is running on the 4507 switch and ip routing doesn't seem to appear in the running-config. Is it possible that when IP CEF is running (IP ROUTING) is already in place. I really appreciate whatever additional information you can provide and thank you again for your help.

--chie

lazon Sun, 04/05/2009 - 04:19

Do you need to enter encapsulation type (like dot1q or ISl) after you enter the VLAN ip address? Thanks again.

ex:

interface vlan 12

ip address 10.1.12.1 255.255.255.0

encapsulation dot1q 12

no shut

--chie

Marwan ALshawi Sun, 04/05/2009 - 14:35

ok for ip routing it is just one command

ip routing [enter]

for encapsulation No you dont need it is like a normal L3 interface

VTP will help you to make sure only the 4507 will creat and remove VLANs

good luck

if helps rate

Actions

This Discussion