Cannot add WLC to WCS

Unanswered Question
Apr 5th, 2009
User Badges:

Hi,


I have just installed WCS demo, and am trying to add a WLC to it.


I keep getting the error :-


No response from device, check SNMP communities, version or network for issues




WCS :- 5.2.130.0

WLC :- 5.0.148



I have SNMP enabled on the WLC, and when I try to add it from WCS (10.1.1.5), I see the following on the WLC


SNMPD: Packet from: 10.1.1.5:4858, in_packet_len = 44

SNMPD: calling srDoSnmp.

SNMPD: received get pdu

SNMPD:calling do_response

Searching for requested instance of sysObjectID

Sending SNMP packet to 10.1.1.5:4858, out_packet_len = 55


It looks like the two apps can communicate via SNMP ...


Any idea what I may be doing wrong ?


Thanks



UPDATE :-


I also updated the WLC to version 5.2.178.0, which is listed as supported in WCS 5.2.130.0


I still get the same error :-


No response from device, check SNMP communities, version or network for issues


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dennischolmes Sun, 04/05/2009 - 19:57
User Badges:
  • Gold, 750 points or more

Where are the two physical devices located? If across an MPLS link or WAN insure that fragmentation is not taking place. The SNMP is very prone to fragmentation when communicating between the two devices. There used to be a max var binds in the pdu file but you can change it now in the gui of the WCS. The default is 100. Make sure that any firewalls allow SNMP traffic both ways for each device as well.

shahedvoicerite Sun, 04/05/2009 - 23:01
User Badges:


The two devices are on a LAN.


I put an ACL on the router which hosts the NM-WLC, to log SNMP packets, and I can see traffic pass through.


So, there is no firewall issue.


I'll check / increase the PDU size.


Thanks

shahedvoicerite Mon, 04/06/2009 - 02:35
User Badges:

Ok, I think it might be a windows problem.


I am running the WCS on a Win2003 server.


I downloaded a SNMP/MIB browser on the Server and cannot reach the WLC using that.


However, I can reach the 2800 series router hosting the NM-WLC with SNMP from the Win2003 server.


I can also reach the WLC from another subnet using SNMP.


I'll have to double check the network connectivity .



Robert.N.Barrett_2 Mon, 04/06/2009 - 04:56
User Badges:
  • Bronze, 100 points or more

I don't mean to sound disrespectful, but, are you using matching SNMP settings (community name, read/write permissions, etc.) on the WLC and WCS? Could something be blocking SNMP traffic (software firewall) on the WCS server? A firewall between the two boxes?

shahedvoicerite Mon, 04/06/2009 - 05:03
User Badges:

Hi Robert,


Thanks for the suggestions...


It is likely that it may be something as trivial as that..


I can browser the WLC MIB from another PC in the same subnet.


When I install the same MIB browser tool on the Win2003 server running WCS, it fails to connect to the WLC....


I can see packets reaching the WLC in both cases, so I am not sure why the return data is not sent back...


I am running the WCS on Win2003 on VMWare, so I dont know if thats affecting it somehow...


I'll keep debugging and post my findings.


Thanks






dennischolmes Mon, 04/06/2009 - 06:27
User Badges:
  • Gold, 750 points or more

Bounce the WCS box. Sometimes the IP stack listening device fails.

gamccall Mon, 04/13/2009 - 14:23
User Badges:
  • Silver, 250 points or more

Also, upgrade your controller! 5.0 code is real messy.

shahedvoicerite Tue, 04/14/2009 - 02:06
User Badges:

OK, the problem is related to VLAN / BVI / packet routing of SNMP replies from the WLC to the WCS.



I have opened up a new thread to discuss this problem.


The workaround for me was to put my WCS in a VLAN that does not have a sub-interface on the router hosting the NM-WLC.


Thanks


shahedvoicerite Wed, 04/15/2009 - 06:23
User Badges:

I think my problem is SOLVED as per the doc snippit below.


I had my WCS in the same vlan as a dynamic interface.


I suppose everyone either keeps the Dynamic interfaces separate from the Management VLANS anyway as a best practice


OR


This issue of asymetric routing occurs only with NM-WLC.




http://www.cisco.com/en/US/tech/tk722/tk809/technologies_tech_note09186a0080810880.shtml



Per design, most of the CPU initiated traffic is sent from the management address in the controller. For example, SNMP traps, RADIUS authentication requests, multicast forwarding, and so forth.


The exception to this rule is DHCP related traffic, which is sent from the interface related to the WLAN settings, for controller software version 4.0 and later. For example, if a WLAN uses a dynamic interface, the DHCP request is forwarded using this Layer 3 address.


This is important to take into account when you configure firewall policies or design the network topology. It is important to avoid configuring a dynamic interface in the same sub network as a server that has to be reachable by the controller CPU, for example a RADIUS server, as it might cause asymmetric routing issues.



tmoffett Mon, 05/24/2010 - 04:17
User Badges:

I was just having the same issue on some home lab gear.


I ran a SNMP debug on the controller CLI and saw that the GET requests were reaching the controller.  I pointed WCS at the AP manager interface that is on the same subnet as the WCS and was finally able to add the controller...


Interesting!


Thanks!!!  I thought I would never figure this out - didn;t realize that the AP manager interface could be used to manage via WCS.


Tim

Actions

This Discussion