Router CPU Utilization High

Answered Question
Apr 5th, 2009

I have the below router in production which is showing CPU usage 100% during some file transfer between the segments.

IOS (tm) C2600 Software (C2600-I-M), Version 12.3(19), RELEASE SOFTWARE (fc2)

I am using only two fast ethernet interfaces on this router which are connected to a cisco switch and are autonegotiated to 100MBPS.

My Queries:

1. How can I see the active traffic session on the router like netstat -n on windows?

2. I have set IP CEF on my router. Is it O.K? Do I need to configure ip route-cache {path}

or Fast switching on any interface? The CPU utilization on my router goes high (around 99%) even when I transfer a 100MB file. How can I troubleshoot this problem?

I have tried Cisco output interpretor without any luck.

I have this problem too.
0 votes
Correct Answer by Joseph W. Doherty about 7 years 8 months ago

10 Mbps might, or might not, bring your CPU load down under 100%. Depends on the specific 2600 model. You could try it, but as Giuseppe recommends, would avoid half duplex.

If 10 Mbps still allows the CPU to go to high, or conversely, you note the CPU stays too low (i.e. you have wasted capacity), you might also try rate-limiting input bandwidth. Rate limiting allows very fine control on bandwidth. It does add some CPU load itself, but I think it's minor.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Giuseppe Larosa Sun, 04/05/2009 - 23:35

Hello Avil,

to see the amount of traffic on interfaces you can

set the load-interval to 30 seconds

conf t

int fas0/0

load-interval 30

end

then use sh int type x/y

to see the top flows for traffic you can enable ip accounting

conf t

int f0/0

ip accounting output-packets

end

wait some time then issue

show ip accounting

2) to check what type of switching is in use on your interface you can use

sh ip int type x/y | inc lags

Example

sh ip int g0/1 | inc lags

IP route-cache flags are Fast, CEF

CEF is the most efficient way to process traffic that needs to be moved between interfaces on the router

you can check the processes that are using more cpu with

sh proc cpu sorted 1min

However, it is possible that this can be caused by traffic.

Edit:

I see that you had already a thread about this issue.

as other collegues (Paolo, Glen and others) has noted a C2600 is simply not enough powerful for handling two FE ports at wire speed.

The suggestion to use a L3 switch is useful and you should look at this upgrade path

Hope to help

Giuseppe

avilt Sun, 04/05/2009 - 23:46

If I set "ip accounting output-packets"

is it going to create problems on router? Is it going to put more load on the router?

Both the interfaces of my router are connected to a 100mbps switch and its not connected to any WAN interface directly.

Giuseppe Larosa Mon, 04/06/2009 - 00:44

Hello Avil,

yes some load is added by the accounting function so in your case is not recommended to enable it.

Sorry for the misleading information

Hope to help

Giuseppe

avilt Mon, 04/06/2009 - 01:52

Thank You again.

Can I set it right by configuring both the interfaces of the router to 10mbps with half duplex. I know its bit awkward but what I feel is since the router is connected to 100mbps switch with full duplex, the router is trying to send data at that speed but cpu is going high.

Note: Due to recession all new procurement is freezed. I am trying to solve this CPU utilization problem what ever possible ways.

Giuseppe Larosa Mon, 04/06/2009 - 02:12

Hello Avil,

your idea can be a solution to limit cpu usage on the router I would configure at 10 Mbps full-duplex on both the router interface and the switch ports

half-duplex provides poor performance try before with full duplex

Hope to help

Giuseppe

Correct Answer
Joseph W. Doherty Mon, 04/06/2009 - 04:17

10 Mbps might, or might not, bring your CPU load down under 100%. Depends on the specific 2600 model. You could try it, but as Giuseppe recommends, would avoid half duplex.

If 10 Mbps still allows the CPU to go to high, or conversely, you note the CPU stays too low (i.e. you have wasted capacity), you might also try rate-limiting input bandwidth. Rate limiting allows very fine control on bandwidth. It does add some CPU load itself, but I think it's minor.

avilt Mon, 04/06/2009 - 18:43

I set interface speed to 10mbps and the cpu utilization never crossed 20%

What is the command to set interface rate limit to 30mbps?

Actions

This Discussion