Sup720 Overrun OID

Unanswered Question
Apr 6th, 2009
User Badges:

Hi,

I have spent days searching for this but have not found it, so I decided to hit the forum.


I have a port on a 6509 with a Sup720, running s72033-ipservicesk9-mz.122-18.SXF10, that is connected to a server. The port is experiencing overruns and it may be causing problems, so I am trying to figure out the OID so I can monitor it.

I tried using cieIfInOverrunErrs, 1.3.6.1.4.1.9.9.276.1.1.1.1.7 located in CISCO-IF-EXTENSION-MIB, but it does not appear to be pulling the information, but maybe it's something I'm doing wrong.


Using the command snmpwalk -c $community -v 2c $hostname. I also tried the -M to use the whole MIB directory, and -m with the specific mib. It is returning information, but does not match the info listed when I do a "sh int gi6/21".


Any help would be greatly appreciated.


Thanks in advance,

Leonard

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
sadbulali Fri, 04/10/2009 - 14:09
User Badges:
  • Bronze, 100 points or more

The most likely causes for this would be:

1. vlans not common on either side of the trunk link

a. in this case --> probably not likely as your drops are not incrementing

2. bursty traffic patterns --> a good test for this would be to clear counters on the interface and check every few hours to validate the lack of a constant incrementing of the counter. If you have situations where there are short periods of bursty traffic, this will be your symptom. Please clear counters on this interfce and watch for this non-ncrementing pattern.


lamav Fri, 04/10/2009 - 17:57
User Badges:
  • Blue, 1500 points or more

Hi, Leonard:


I know that what I am about to give you is a non-answer regarding your specific concern, but I think the more appropriate track to take here is to determine why you have overruns in the first place, and not so much being able to know when you do.


Incrementing overruns means that your switch interface is receiving traffic faster than it can process. It uses its buffers, and when those buffers get full, packets start to get dropped.


Your switch port and your NIC card are supposed to be transferring data at an agreed rate and manner (100/full...10/full...etc), so the server should not be sending data faster than the interface speed on the switch.


You may have a bad switchport, a faulty line card, a problem with the switch bus (if other ports are behaving the same way), or maybe a case of oversubscription.


I dont have the answer, but I will say that I think the more important thing to do is address the failure and not focus too much on knowing when the failure occurs.


HTH


Victor

Actions

This Discussion