IOS DHCP server

Unanswered Question
Apr 7th, 2009

My router is setup with two vlans on ethernet subinterfaces using dot1q. However, when my wireless clients try to get a dhcp address from the router, it hands out the address from the domain controller. Here are my router settings. Trunks have been verified. My guest wireless is on vlan 50

interface GigabitEthernet0/0.1

encapsulation dot1Q 60

ip address 10.3.5.132 255.255.255.224

ip hello-interval eigrp 10 1

ip hold-time eigrp 10 3

no snmp trap link-status

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 50

ip address 192.168.5.1 255.255.255.0

no snmp trap link-status

no ip dhcp use vrf connected

ip dhcp excluded-address 192.168.5.1 192.168.5.10

!

ip dhcp pool DT-GUEST

network 192.168.5.0 255.255.255.0

dns-server 4.2.2.2

default-router 192.168.5.1

lease 7

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
John Blakley Tue, 04/07/2009 - 07:02

I don't know what kind of AP you have, but you'll need to make sure that the ssid that they connect to is associated to vlan 50. In a Cisco AP, it would look something like this:

dot11 ssid test

vlan 50

int do0

no ip address

ssid test

int do0.50

encap dot1q 50

no ip address

bridge-group 50

int fa0.50

encap dot1q 50

bridge-group 50

int bvi1

ip address 10.3.5.132.100 255.255.255.224

When the client associates to ssid test, it will map to vlan 50 and then pull the correct address. Otherwise, it will come over the default vlan, and it'll never hit the correct vlan.

HTH,

John

omar.elmohri Tue, 04/07/2009 - 07:05

In your case, both Router and Domain controller give a DHCP reply. and the DC is faster arriving to the client.

You would try to disable the DHCP server on the VLAN 50 or block the DHCP in the VLAN.

jgorman1977 Tue, 04/07/2009 - 07:42

One issue i noticed is that i had an ip helper statment on the same subnet as the guest wireless. My ACL's should take care of the DHCP requests to the DC.

Thank you!

omar.elmohri Tue, 04/07/2009 - 07:47

Please,

Can you send the command ? is to implemented on the VLAN 50 ?

This means that all DHCP is forwarded to the IP mentioned on the command. And you have to remove it, so no forwarding of DHCP request will be to DC.

Regards,

Omar

Please rate if that help.

Leo Laohoo Tue, 04/07/2009 - 14:32

Can't you use "ip helper address" on your AP?

Is it a Cisco AP? Is it Autonomous or LWAP IOS?

jgorman1977 Thu, 04/09/2009 - 07:21

Didn't think about that, but got it working by putting the scope on our L3 switch.

omar.elmohri Sat, 04/11/2009 - 01:26

First, Have you tried to remove the ip-helper address on the Guest-VLAN.

Next, Put the DHCP scope on the L3 switch to give IPs to guest users.

Then, Give back a reply and I still following the progress with you.

Regards,

Omar

Actions

This Discussion