weird 3750 stack ,

Answered Question
Apr 7th, 2009
User Badges:

our client have a c3750-stack by using the stack-wise cable,, there is 6 c3750 stack as 1 switch. we enable the port-security in all the ports for user. the problem is the port random erri-diabled by the mac-address. this mac-address actully learn from another port. for example, f2/0/24 is erri-disable,casue this is by aaaa.aaaa.aaaa,, and this mac-address actully learned from f5/0/43.

after I sh/no-sh the port ,, the port is back to normal.but few hours later,, this thing happened again , and this time ,it is another 2 port involved in.


need help from you guys

Correct Answer by greg.washburn about 8 years 1 month ago

We had a similar problem and as part of an additional ssh problem we installed the latest IOS (122-50.SE). Fixed ssh and the problem you mention above.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Hieu Cao Tue, 04/07/2009 - 13:59
User Badges:

Need more info from you..


1. what is the current aging time set for port-security?


2. For the mac-addresses in conflict that's shutting down the port, what device is it? Laptop?


3. Do you have "sticky" option enabled? From what you described, I think not, but I just to make sure. Don't enable "sticky" option unless you've a real business needs for it.


4. Is it the same mac-add that has been causing the problem or different mac-addresses every time?


5. Sounded like the problem arose after you implemented port-security, is it correct?


6. Can you post the switchport config?


Good luck.

rubberheart Tue, 04/07/2009 - 16:37
User Badges:

thanks for your reply

here is the information:

1. what is the current aging time set for port-security?

it is default setting


2. For the mac-addresses in conflict that's shutting down the port, what device is it? Laptop?

yes,,ladtop,,some of them running VM


3. Do you have "sticky" option enabled? From what you described, I think not, but I just to make sure. Don't enable "sticky" option unless you've a real business needs for it.

no,we don't enable that feature


4. Is it the same mac-add that has been causing the problem or different mac-addresses every time?

no, it is random mac-address.


5. Sounded like the problem arose after you implemented port-security, is it correct?

no, we have run this stack for 3 weeks, and this issue just came last weekend.


6. Can you post the switchport config?

just for example,portf1/0/24


int f1/0/24

sw mo acc

sw acc vlan 74

sw port

sw port max 1

sw port violation restrict

spanning portfast

spanning bpduguard enable


------------------------------------

thx


Correct Answer
greg.washburn Tue, 04/07/2009 - 14:02
User Badges:

We had a similar problem and as part of an additional ssh problem we installed the latest IOS (122-50.SE). Fixed ssh and the problem you mention above.

rubberheart Thu, 04/09/2009 - 07:31
User Badges:

finnaly , we catched the bad guy,, who is act as a bad dhcp server,,but thanks guys

Actions

This Discussion