Route problem on PPP FR- Virtual Templete

Unanswered Question
Apr 7th, 2009

Hi,

Eigrp or OSPF networks are not advertise on FR links on PPP Virtual templete. Please help.

R4(config)#int virtual-template 1

R4(config-if)#ip address 141.141.45.4 255.255.255.0

R4(config-if)#exit

R4(config)#int s1/0

R4(config-if)#encapsulation frame-relay

R4(config-if)#frame-relay interface-dlci 405 ppp virtual-Template 1

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
srinivas_816 Tue, 04/07/2009 - 22:33

are you doing any multilink

is you serial link up and reachable

First ensure that the link is up and reachable and then configure the EiGRP

if you are configuring an Multilink over Frame relay then please use the sample configs, and then configure the Eigrp or OSPF

if yes then plz first configure the

interface Multilink1

ip address A.B.C.D 255.255.255.

ppp multilink

ppp multilink group 1

and Add the multilink to the interface Virtual-templet 1

interface Virtual-Template 1

bandwidth 1536

no ip address

ppp multilink

ppp multilink group 1

interface Serial0/1/0:0

no ip address

encapsulation frame-relay

frame-relay lmi-type ansi

!

interface Serial0/1/0:0.1 point-to-point

frame-relay interface-dlci 312 ppp Virtual-Template1

Rupesh Kashyap Tue, 04/07/2009 - 22:56

Hi,

I am not using Multilink. This is PPP over Frame Relay. The problem is,Eigrp neighbor is established, but Networks are not advertised on peer end. I have tried many times, but still N/W is not advertise. Please help.

Giuseppe Larosa Wed, 04/08/2009 - 00:03

Hello Rupesh,

you say that the EIGRP neighbors are formed but you don't see the routes:

have you checked this using

sh ip eigrp topology

because there is the possibility that better routes are learned through another path.

also if you can post

sh ip eigrp neigh note the Q count in an healthy network this number has to be zero.

if there are pending EIGRP updates not ack by the neighbor this number is not zero.

Also you may need to adjust the ip MTU.

There was another thread reporting problems of missing EIGRP routes.

After troubleshooting with debug commands the problem was that depending on the size of the subnets to be advertised the size of each route data structure varies TLV (for a padding field) and so varies the size of the EIGRP update packet that carries mutiple TLVs of routes

Hope to help

Giuseppe

Rupesh Kashyap Wed, 04/08/2009 - 00:46

Hi Sir,

I am only facing the problem if i create Virtual Templete. I have made the same setting which you have recommanded. If I remove Virtual Tunnel,every things work on FR. Any Clue.....

Giuseppe Larosa Wed, 04/08/2009 - 00:57

Hello Rupesh,

when you use the virtual-template you are putting a ppp frame inside a FR frame.

the suggestion is

int virtual-template xx

ip mtu 1480

Hope to help

Giuseppe

Giuseppe Larosa Wed, 04/08/2009 - 01:29

Hello Rupesh,

so it is not an MTU issue.

Now, to see if this can be an issue related to multicast

router eigrp xx

neighbor x.y.z.k

we try to use only unicast packets for EIGRP communication

Hope to help

Giuseppe

Rupesh Kashyap Wed, 04/08/2009 - 01:33

Hi, Good Idea to send the unicast,I haven't tried this. I would do it on tomorrow morning, and update you accordingly. Hope it should work.

Rupesh Kashyap Wed, 04/08/2009 - 20:35

Hi, I did it , but it is not working. The have some clue- Show Fram-relay Map command is not showing any mapping. I manually mapped too, but eigrp is not sending the updates. If we debug, then multicast packets are being send/receive on virtual templete. Please help.

Rupesh Kashyap Wed, 04/29/2009 - 19:54

Hi Champions. Please help me. I also tried to establish EIGRP Unicast (neibhor command), still Routes are not published on Virtual Templete on FR.

Rupesh Kashyap Wed, 04/29/2009 - 21:03

Hi, Should I use Static mapping too ??

R4(config-if)#frame-relay interface-dlci 405 ppp virtual-Template 1

R4(config-if)#frame-relay map ip 141.141.45.5 405 broadcast

Actions

This Discussion