2821 - issues

Unanswered Question
Apr 8th, 2009

Hy,

Here's bootup log:

Cisco 2821 (revision 49.46) with 118784K/12288K bytes of memory.

Processor board ID FCZ101372P9

4 FastEthernet interfaces

2 Gigabit Ethernet interfaces

2 Virtual Private Network (VPN) Modules

DRAM configuration is 64 bits wide with parity disabled.

239K bytes of non-volatile configuration memory.

253008K bytes of ATA CompactFlash (Read/Write)

% Crashinfo may not be recovered at flash:crashinfo

% This file system device reports an error

Press RETURN to get started!

*Apr 8 11:13:27.187: %ESWMRVL_FLTMG-5-NOTICE: Notice: FPGA Rev 0x71

*Apr 8 11:14:32.827: %VPN_HW-6-INFO_LOC: Crypto engine: aim 0 State changed to: Initialized

*Apr 8 11:14:32.827: %VPN_HW-6-INFO_LOC: Crypto engine: aim 0 State changed to: Enabled sslinit fn

*Apr 8 11:14:35.191: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0 State changed to: Initialized

*Apr 8 11:14:35.191: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0 State changed to: Disabled

*Apr 8 11:14:35.903: %SW_VLAN-4-IFS_FAILURE: VLAN manager encountered file operation error: call = ifs_open/read / code = 2595 (No device available)

/ bytes transfered = 0

*Apr 8 11:14:35.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface VoIP-Null0, changed state to up

*Apr 8 11:14:35.911: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up

*Apr 8 11:14:35.911: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed state to up

*Apr 8 11:14:36.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down

*Apr 8 11:14:36.911: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to down

*Apr 8 11:14:37.867: %VPN_HW-6-INFO_LOC: Crypto engine: onboard 0 State changed to: Disabled

1. I wanted to load a newer IOS image and because it has 38mb I couldn't load by TFTP; I wrote down the image using a CF reader, router is booting up, but I receive this message: % This file system device reports an error

If I am to run: show flash, here's the output:

Cisco_2821#show flash

%Error show flash: (No device available)

2. Cisco_2821(config)#crypto engine ?

accelerator Crypto hardware device

aim Advanced Integration Module

onboard Onboard Crypto Engine

software Software crypto engine

What engine should I use, and what should I disable ?

3. What is best practice for an 2821 regarding installed memory, is it worth to upgrade to 512, or 256 will just be enough?

Kind regards,

Florin.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
Giuseppe Larosa Wed, 04/08/2009 - 04:47

Hello Florin,

1) use FTP instead of TFTP and have the router to write the image by itself on the flash/CF it is the safest choice

2) probably AIM that should be present check with sh diag

3) follow the requirements of the new IOS image if it asks for more memory be prepared to install it

Hope to help

Giuseppe

Florin Barhala Wed, 04/08/2009 - 06:49

Hello Giuslar,

1. I tried using an FTP server, but no luck as I was knocked out by some errors, and went out for the fast solution and copied it using a CF reader. Still in order to get rid of that error I have to upload that IOS by TFTP ?

2. I attached show diag output, which is gonna be, then ? the onboard one? I don't know which is best: AMI or onboard ?

3. Most of the IOS images require 256 RAM, but I was asking if it is any use of a 512 module?

Regards,

Florin.

Attachment: 
t-yamashita Wed, 04/08/2009 - 21:47

hello Florin,

>Still in order to get rid of that error I have to upload that IOS by TFTP ?

I think, there's good chance of that, yes.

Could you tell me what are the IOS image and TFTP server?

And Could you post the "show version"?

Best regards,

Tomoyuki

Florin Barhala Wed, 04/08/2009 - 22:22

Regarding the flash error, I can't upload anything via TFTP as the flash is no longer available:

Cisco_2821#show flash:

%Error show flash: (No device available); I did not format the CF, I just copied the IOS I wanted to run, and that's it.

As you can see in the attached file, I m running a Advanced IP Services version, instead of IPversion I had before.

As TFTP server, I tried with SolarWinds, first with an older version and then with the newest version find on their website.

About VPN Module, you see I have two, which of them should I be using?

Regards,

Florin.

Leo Laohoo Wed, 04/08/2009 - 22:37

Depending on your ROMmon and or IOS (USB support starts from 12.4(4)), you can boot from a USB stick. I know I've done this several times.

ROMmon v12.4(13r)T (C2800NM_RM2.srec.124-13r.T) is described as "adds boot from USB flash drive capability".

Use the command "boot system usbflash0:". Exit the configuration mode and save the configuration.

Note: "boot system usbflash0:", particularly the "usbflash0:" bit will not appear as an option so you need to enter the entire word in.

Have a look below:

Router#dir

Directory of flash:/

1 -rw- 30331404 Nov 12 2008 15:33:12 +00:00 c2800nm-spservicesk9-mz.124-3i.bin

64016384 bytes total (28999680 bytes free)

Router#dir usb

Router#dir usbflash0:

Directory of usbflash0:/

1 -rw- 34518464 May 14 2008 05:48:46 +00:00 c3845-advipservicesk9-mz.124-7g.bin

2 -rw- 1623191 Sep 5 2008 00:38:12 +00:00 C2800NM_RM2.srec.124-13r.T6

3 -rw- 18749384 Oct 27 2008 05:17:04 +00:00 c1841-advsecurityk9-mz.124-7g.bin

4 -rw- 20404320 Mar 7 2008 06:29:28 +00:00 c2800nm-advsecurityk9-mz.124-7g.bin

5 -rw- 1690523 Oct 3 2008 01:16:02 +00:00 C1841_RM2.srec.124-13r.T5

6 -rw- 34124956 May 14 2008 05:44:34 +00:00 c2800nm-advipservicesk9-mz.124-7g.bin

7 -rw- 21818492 Mar 1 2002 00:27:16 +00:00 c870-advipservicesk9-mz.124-24.T.bin

257187840 bytes total (123949056 bytes free)

Router#sh run | i boot system

boot system usbflash0:c2800nm-advipservicesk9-mz.124-7g.bin

Router uptime is 1 minute

System returned to ROM by reload at 22:57:24 UTC Mon Apr 6 2009

System image file is "usbflash0:c2800nm-advipservicesk9-mz.124-7g.bin"

DISCLAIMER: Use NON-Cisco certified USB/Compact Flash cards at your own risk. The author is not responsible for any use of NON-Cisco certified USB/Compact Flash cards incorrectly, inappropriately and will not take responsibility if your appliance(s) fail because of it. I was forced to use NON-Cisco certified USB/Compact Flash cards because my employer is a tight-a$$!

HAPPY EASTER!

Florin Barhala Wed, 04/08/2009 - 22:58

My router is booting and running perfectly; it s just I want to get rid of that error, so if I will boot up from USB, will the error be gone?

t-yamashita Thu, 04/09/2009 - 00:02

Thank you for your posting.

First of all, "AIM-VPN/EPII-PLUS" requires 12.4(T)

Take a look at following page:

http://www.cisco.com/en/US/prod/collateral/routers/ps5854/prod_qas0900aecd80516d81_ps6635_Products_Q_and_A_Item.html

Therefore, you can't use "crypto engine aim".

And perhaps you can't use "crypto engine accelerator, onboard and software" too by the IOS malfunction for any reason.

I'm sorry to disappoint you.

Tomoyuki

t-yamashita Thu, 04/09/2009 - 02:34

Hello Leo

>>you can boot from a USB stick.

I didn't think of that.

It was a good lesson for me.

Thanks

Tomoyuki

Florin Barhala Thu, 04/16/2009 - 06:10

Ok, I have installed 12.4(11)T;

In my CF reader, I see the card with FAT file system; if I am to format to another file type you think it will work ?

What the default file type used on Cisco flash cards?

L.E. After the boot I still receive that error: This file system device reports an error.

I read smthg on google answer to this error, but got nothing, yet.

I tried to format it, from Cisco CLI, and here s the output

Cisco2821#format flash:

Format operation may take a while. Continue? [confirm]

Format operation will destroy all data in "flash:". Continue? [confirm]

%Error formatting flash (No device available)

mgeorge27 Mon, 03/19/2012 - 20:27

I know i'm resurecting this post from the grave but I've recently ran into this issue and have found a solution to this problem. Hopefully this will help others with the same issue.

Initially i thought the flash cards were bad however i knew they wernt. 3 flash cards dont go bad at the same time. I noticed my problem being tied to a downgrade from 12.4(24)T to 12.4(15)T

The router acted as if the flash was not there, gave me errors and couldnt format/erase it.

I took the card out and put it into the PC than formatted it with NTFS. Than reinstalled it back into the router and the router than was able to see the card. Formated it than from the router cli and was able to http/ftp an image onto it and reload it and it worked just fine.

I'm not for sure if this is a Cisco issue or if its a windows issue causing the FAT to mess up when writing new filese to the file system on the flash card. Hope this fixes you're guys issue.

Actions

This Discussion