cisco to nortel callpilot vm

Unanswered Question
Apr 8th, 2009

have been working on a cisco/nortel integration for a while. we have cucm 6.1.2 with a mgcp controlled 2811 with qsig pri to a nortel opt 61 running v5.5.

we are trying to give cisco ip phones a nortel callpilot vm.

when the call is initiated from the nortel side it works. q931 debug from when nortel set 1345 calls 2330 (which is cdp'd off nortel to cisco and that 2330 dn is assigned to a cisco phone with cfna to vm pilot to callpilot):

8 13:38:23.115: ISDN Se1/0/0:23 Q931: RX <- SETUP pd = 8 callref = 0x217A

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9838F

Exclusive, Channel 15

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x4980, '1345'

Plan:Private, Type:Subscriber(local)

Called Party Number i = 0xC9, '2330'

Plan:Private, Type:Subscriber(local)

Sending Complete

Apr 8 13:38:23.151: ISDN Se1/0/0:23 Q931: TX -> CALL_PROC pd = 8 callref = 0xA17A

Channel ID i = 0xA9838F

Exclusive, Channel 15

Apr 8 13:38:23.151: ISDN Se1/0/0:23 Q931: TX -> ALERTING pd = 8 callref = 0xA17A

Facility i = 0x9FAA06800100820100A114020101020101800C43616C6C50696C6F7420444E

Progress Ind i = 0x8088 - In-band info or appropriate now available

bcsofc2811#

bcsofc2811#

Apr 8 13:38:25.383: ISDN Se1/0/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0xA07A

Cause i = 0x8190 - Normal call clearing

Apr 8 13:38:25.411: ISDN Se1/0/0:23 Q931: RX <- RELEASE pd = 8 callref = 0x207A

Apr 8 13:38:25.447: ISDN Se1/0/0:23 Q931: TX -> RELEASE_COMP pd = 8 callref = 0xA07A

Apr 8 13:38:28.143: ISDN Se1/0/0:23 Q931: TX -> FACILITY pd = 8 callref = 0xA17A

Facility i = 0x9FAA06800100820100A165020200A1020113305C0A01038001033006800436373235020101400504038090A2A108A006800432333330820102A40BA0098004313334350A0103A608A006800432333330A70E800C43616C6C50696C6F7420444EA80E800C43616C6C50696C6F7420444E

Apr 8 13:38:28.207: ISDN Se1/0/0:23 Q931: RX <- FACILITY pd = 8 callref = 0x217A

Facility i = 0x9FAA06800100820100A20B020200A130050201130500

Apr 8 13:38:28.211: ISDN Se1/0/0:23

when initiated from the cisco side the call is always sent over the qsig pri like its a brand new call and we always get the default opening greeting on callpilot:

Sending Complete

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x4981, '6674'

Plan:Private, Type:Subscriber(local)

Called Party Number i = 0xC9, '6725'

Plan:Private, Type:Subscriber(local)

Redirecting Number i = 0x000082, '2330'

Plan:Unknown, Type:Unknown

Apr 8 13:28:47.223: ISDN Se1/0/0:23 Q931: RX <- STATUS pd = 8 callref = 0x8008

Cause i = 0x81E3 - Information element not implemented

Call State i = 0x06

Apr 8 13:28:47.227: ISDN Se1/0/0:23 Q931: RX <- CALL_PROC pd = 8 callref = 0x8008

Channel ID i = 0xA98381

Exclusive, Channel 1

Apr 8 13:28:47.235: ISDN Se1/0/0:23 Q931: RX <- ALERTING pd = 8 callref = 0x8008

Apr 8 13:28:47.959: ISDN Se1/0/0:23 Q931: RX <- CONNECT pd = 8 callref = 0x8008

Connected Number i = 'i', 0x80, '6725'

Apr 8 13:28:47.967: ISDN Se1/0/0:23 Q931: TX -> CONNECT_ACK pd = 8 callref = 0x0008

Apr 8 13:28:51.255: ISDN Se1/0/0:23 Q931: TX -> DISCONNECT pd = 8 callref = 0x0008

Cause i = 0x8190 - Normal call clearing

i have had 2 tac cases - 1 is still open

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
gogasca Thu, 04/09/2009 - 00:35

Calling Party Number i = 0x4981, '6674'

Plan:Private, Type:Subscriber(local)

Called Party Number i = 0xC9, '6725'

Plan:Private, Type:Subscriber(local)

Redirecting Number i = 0x000082, '2330'

Apr 8 13:28:47.223: ISDN Se1/0/0:23 Q931: RX <- STATUS pd = 8 callref = 0x8008

Cause i = 0x81E3 - Information element not implemented

1. We inmediatly get the status message.

I assume nortel side should enable incoming redirect field for Q.SIG protocol.

2. What you see in the CallViewer for Nortel Pilot.

3. Nortel is able to see a Redirect call or at least a Redirect Reason?

Can you please upload ccm sdi and sdl detailed trace file checked All Gateway trace.

Thanks

jim-stewart Fri, 04/10/2009 - 08:28

well, as it turns out qsig was apparently not going to work for this integration. not saying it wont work for yours, but it wouldnt for mine. working with nortel engineer we flipped the pri protocol to dms100 on cisco and sl100 on nortel and BAM! all calls work - including all forwarding behavior. we have lost mwi function, at least for the moment. a different nortel guy tells me there is a way for nortel to send me the mwi on/off info over this type of trunk. i havent seen it yet tho.

i have closed my tac case over the qsig issue as well.

to answer gogasca's ?'s:

1 - i assumed that also.

2 - they couldnt turn that on due to it requiring registry work and a reboot

3 - when i send redirect (of any kind) the nortel would send me back 2 error messages and they couldnt actually see that info on their d-ch messaging anyway...

thanks!

ecornwell Mon, 04/13/2009 - 05:32

We have a working QSIG install with our Opt 81c. We use CallPilot for the majority of our Cisco VoIP users. MWI and and all VM functionaility works as far as I can tell. We've been running this way for over 2 years now.

I had to make some changes in the way that CCM sent the information to the Nortel.

I set the following:

Called party IE Number Type unknown - Subscriber

Calling party IE Number Type unknown - Subscriber

Called Numbering Plan - Private

Calling Numbering Plan - Private

Once I set those settings on the PRI, everything worked great.

jim-stewart Wed, 04/15/2009 - 13:00

ecornwell - we had everything working on the qsig except for the callforward behaviors rolling to the callpilot...the nortel couldnt recognize the originalcalled number, so the cfb/na would always roll the the default greeting as opposed to getting to the correct vm box for the greeting to play...

i too know this works - have set it up at other customers before. issue is - and tac wont help me anymore til i get this - what is nortel looking for? specifically - what field and format should the original called number be in...not being a nortel guy i cant answer that.

our current install has been moved to a dms-100 to sl-100 trunk and all works now except mwi...ugh...

i see in the q931 debug the mwi info coming back to the cisco side but i dont know what that info is or how to program the cisco to understand it...here it is:

Apr 15 19:38:20.848: ISDN Se1/0/0:23 Q931: RX <- FACILITY pd = 8 callref = N/A

Locking Shift to Codeset 6

Codeset 6 IE 0x1 i = 0x8C8104, '6725'

Codeset 6 IE 0x2 i = 0x8C8104, '2330'

Codeset 6 IE 0x1C i = 0x12E1E21AC7040000, 'T', 0x12E812E910CF0100D0028A01F207AA0592038090A2

anybody got any advice on mwi over dms100 pri?

Actions

This Discussion