FAX-MAIL on 2801

Answered Question
Apr 9th, 2009


I m trying to set up FAX-MAIL on 2801 with this IOS :


I want to receive fax on this external number : 0467XXXXXX and to forward them to [email protected] on a server A.B.C.D.

Here the part concerned by this configuration :

dial-peer voice 7932 mmoip

service fax_on_vfc_onramp_app out-bound

destination-pattern XXXXXXXX

information-type fax

session target mailto:[email protected]


dial-peer voice 7933 pots

service onramp

incoming called-number XXXXXXXX


For the called number and destination pattern I have put the full number externa without the 0.

Like 0123456789 => 123456789

Here the symptom, I try to call, and the operator tells me : Unknow number.

I Have 20 number attributed from the operator and this 1 is between 2 of them.

Do I have miss a thing ?

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 7 years 6 months ago

Check with "debug isdn q931" and "term mon" that your XXXXX number is exactly as received from telco. Also, check with "debug voice application script" that no other errors are thrown.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Correct Answer
Paolo Bevilacqua Thu, 04/09/2009 - 01:46

Check with "debug isdn q931" and "term mon" that your XXXXX number is exactly as received from telco. Also, check with "debug voice application script" that no other errors are thrown.

yousri.granier Thu, 04/09/2009 - 01:54

Thanks for your answer.

I Have that

Apr 9 09:51:46.925: %ISDN-3-LAYER2_UP: Layer 2 for Interface BR0/2/1, TEI 0 changed to up

Apr 9 09:51:46.933: %LINK-3-UPDOWN: Interface BRI0/2/1, changed state to up

Apr 9 09:51:47.001: ISDN BR0/2/1 Q931: RX <- SETUP pd = 8 callref = 0x39

Sending Complete

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0x8A

Exclusive, B2

Calling Party Number i = 0x2183, 'XXXXXXXX'

Plan:ISDN, Type:National

Called Party Number i = 0xA1, 'AAAAAAAA'

Plan:ISDN, Type:National

Apr 9 09:51:47.017: ISDN BR0/2/1 Q931: TX -> CALL_PROC pd = 8 callref = 0xB9

Channel ID i = 0x8A

Exclusive, B2

Apr 9 09:51:47.049: ISDN BR0/2/1 Q931: TX -> DISCONNECT pd = 8 callref = 0xB9

Cause i = 0x8081 - Unallocated/unassigned number

Apr 9 09:51:47.101: ISDN BR0/2/1 Q931: RX <- RELEASE pd = 8 callref = 0x39

Apr 9 09:51:47.105: ISDN BR0/2/1 Q931: TX -> RELEASE_COMP pd = 8 callref = 0xB9

Where AAAAA is the good number for the fax

Paolo Bevilacqua Thu, 04/09/2009 - 02:05

Means the configuration is not complete:


service xxx

Note you need a reboot to make the embedded script appear after configuration.

yousri.granier Thu, 04/09/2009 - 02:21

Oh I have forget to paste that :

fax receive called-subscriber $d$

fax interface-type fax-mail

mta send server A.B.C.D port 25

mta send with-subject both

mta send mail-from hostname gw.fax.net

mta send mail-from username $s$



service onramp flash:app_faxmail_onramp.


Already done.

But, When I configure an ephone I just indicate the last 4 digit. like 7932. Not the complete number.

Do you think It could be that ?

Paolo Bevilacqua Thu, 04/09/2009 - 02:24

No, it is not that. Have you rebooted the router? The dubug command I've indicated above will tell you if any problem with the script.

yousri.granier Thu, 04/09/2009 - 02:55

Ok, I haven't seen that i have a translation rule. I change the full number for just the last 4 digit.

It's anwsering now, but the .tif received is only 2 octet.

Perhaps there is another problem.

yousri.granier Mon, 04/20/2009 - 23:07

I have updated to


And still have the same problem.

In fact I have incomplete Fax with :

- A normal fax connect to ATA188

- H323 FAX with T38modem and Hylafax

- fax-mail from cisco.

In attachement, an exemple of the incomplete fax. One received by Hylafax with T38modem, and other with T37 onramp fax-mail.

yousri.granier Mon, 05/25/2009 - 01:19


I ve tried with another IOS, another router, with another line (E1/ T2 in france) and have still this problem.

When I send only 1 page document : No problem all is fine.

When I send 2/3 page : The fax is not complete....

It seems like the router cannot handle big fax in T37 mode...

Some one could help me on this problem ?


This Discussion