UCCX 7.0 SQL Query: Rows Returned = 0

Unanswered Question
Apr 9th, 2009
User Badges:

Hello,

I haven't done a db dip in UCCX for a while. I've the following setup for initial testing and I'm getting:

Number of rows returned: 0 [from the DB Read step Test Button]

When I look at this table via Microsoft Ent Manager there's plenty of rows in the table. When I fire the reactive debugger up the script drops down to the SQL Error from the DB Read Step.


Datasource Name: dsn_cra

User Name: CRSAdministrator


General:

DB Resource Name: getAreaCode

Data Source Name: dsn_cra

Timeout: 7


Field Selection:

SELECT *

FROM AgentConnectionDetail


Any help appreciated.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
raulhersan Wed, 06/03/2009 - 04:50
User Badges:

Hello micandre:


I have the same problem than you, the ODBC connection is configured ok, from the SQL Query Analyzer y get plenty of rows, but from the script i get Number of rows returned: 0.


Did you solve the problem? how? could you post it?


Thank you, Best Regards.


clarkjaso Wed, 06/03/2009 - 07:43
User Badges:

The UCCX 7 SQL DB is in windows only authentication mode by default. If you are using a local SQL user you have to enable mixed mode authentication by right clicking on the server in enterprise manager and going to properties, then the security tab. Cisco does not recommend this however, it should let your query go through. Otherwise use a windows user in the dsn to access the info.

Actions

This Discussion