Issue with Equal Cost Static Default Routes

Unanswered Question
Apr 9th, 2009
User Badges:

Question:


I'm trying to troubleshoot an issue with equal cost static default routes. Here is the configuration of the 3560:


..

interface FastEthernet0/1

no switchport

ip address 8.8.8.1 255.255.255.0

!

interface FastEthernet0/2

no switchport

ip address 9.9.9.1 255.255.255.0

!


interface Vlan1

ip address 50.50.50.1 255.255.255.0

!

....

!


ip route 0.0.0.0 0.0.0.0 8.8.8.2

ip route 0.0.0.0 0.0.0.0 9.9.9.2



"show ip route" output


Gateway of last resort is 9.9.9.2 to network 0.0.0.0


50.0.0.0/24 is subnetted, 1 subnets

C 50.50.50.0 is directly connected, Vlan1

8.0.0.0/24 is subnetted, 1 subnets

C 8.8.8.0 is directly connected, FastEthernet0/1

9.0.0.0/24 is subnetted, 1 subnets

C 9.9.9.0 is directly connected, FastEthernet0/2

S* 0.0.0.0/0 [1/0] via 9.9.9.2

[1/0] via 8.8.8.2


I'm pinging 4 different IPs out in the cloud with two equal cost default routes configured on a 3560. The IPs that I'm trying to ping are 1.1.1.1, 2.2.2.2, 3.3.3.3, and 4.4.4.4 - sourcing from 50.50.50.50. However, when I ping all four IP simutaneously it only egresses the 8.8.8.0 gateway.


I've used the "show ip cef exact-route" output. Which looks like it should distribute the load based on destination.



Switch#sh ip cef exact-route 50.50.50.1 1.1.1.1

50.50.50.1 -> 1.1.1.1 => IP adj out of FastEthernet0/1, addr 8.8.8.2


Switch#sh ip cef exact-route 50.50.50.1 2.2.2.2

50.50.50.1 -> 2.2.2.2 => IP adj out of FastEthernet0/1, addr 8.8.8.2


Switch#sh ip cef exact-route 50.50.50.1 3.3.3.3

50.50.50.1 -> 3.3.3.3 => IP adj out of FastEthernet0/2, addr 9.9.9.2


Switch#sh ip cef exact-route 50.50.50.1 4.4.4.4

50.50.50.1 -> 4.4.4.4 => IP adj out of FastEthernet0/1, addr 8.8.8.2



"show ip cef" output

Switch#sh ip cef

Prefix Next Hop Interface

0.0.0.0/0 8.8.8.2 FastEthernet0/1

9.9.9.2 FastEthernet0/2


"traceroute" output


Tracing the route to 1.1.1.1


1 8.8.8.2 0 msec

9.9.9.2 0 msec

8.8.8.2 0 msec



Any thoughts to why it only goes out one gateway and not both based on the cef table?


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Thu, 04/09/2009 - 07:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Denny,


Your equal cost static routing is working but the result is not showing as expected since you are doing it from the switch itself.


Best to setup a couple of clients in Vlan1 targeting different destinations to see the full effect.


__



Edison.

denny.lee Thu, 04/09/2009 - 07:17
User Badges:

I've tried this from several different hosts connected to the switch with the same results.

Edison Ortiz Thu, 04/09/2009 - 08:14
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

From the traceroute you've shown, it's displaying the load-balancing taking effect.


__


Edison.

denny.lee Thu, 04/09/2009 - 08:40
User Badges:

Yeah. That was the output from the switch and how packets should be traversing to the respective destinations. Testing is a different story altogether. Once I have multiple hosts connected to the switch each simultaneously pinging all the hosts mentioned - all traffic leaves one interface.

Actions

This Discussion