LMS 3.1 Backup error - opsxmleng error

Unanswered Question
Apr 9th, 2009
User Badges:

We have a nightly backup within LMS 3.1 which backs upto a directory on our C drive. I've started receiving the following error within the dbbackup.log -


ERROR (951): FATAL error: Database engine 'opsxmleng' could not be started on database 'opsxml' in Bulk mode.. Backup failed.


Has anyone seen this issue before ?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Thu, 04/09/2009 - 09:09
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

This points to either a problem with the database transaction log, or the database itself. Since the OpsXML database is not that critical, it is not a big deal to reinitialize it.


Shutdown Daemon Manager, then run:


NMSROOT/bin/perl NMSROOT/bin/dbRestoreOrig.pl dsn=opsxml dmprefix=Opsxml


After that, restart Daemon Manager, and your backups should work.

dmistry21 Fri, 04/10/2009 - 10:48
User Badges:

Thanks for the response Joe.


I ran the command as suggested after carrying out a "net stop crmdmgtd" and received the following response:


C:\Program Files\CSCOpx\bin>perl dbRestoreOrig.pl dsn=opsxml dmprefix=Opsxml


WARNING: Existing contents of opsxml database will be lost.

Do you want to continue [y/n]?y

WARNING: Could not delete file C:\PROGRA~1\CSCOpx\databases\opsxml\opsxml.db

WARNING: Could not delete file C:\PROGRA~1\CSCOpx\databases\opsxml\opsxml.log

ERROR: Service - 'OpsxmlDbEngine' is not stopped


opsxml registration failed

Starting database engine opsxmlEng

ERROR: Failed to authenticate [opsxml] database.

Database engine 'opsxmlEng' could not be started on database 'opsxml' in Bulk mo

de.INFO: Calling OpsConfUpdate executable for changing cwa password.

Successfully updated the CWA Engine Configuration file.

opsxml database initialization failed.


Unsure why it thought OpsxmlDbEngine was still running as all processes were stopped. However the backup is scheduled to run this evening so will post what the result is from the dbbackup.log.


Thanks

Joe Clarke Fri, 04/10/2009 - 10:51
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Something is still not right. Please post a screenshot of your Services control panel showing all of the CiscoWorks services.

dmistry21 Fri, 04/10/2009 - 11:11
User Badges:

I've attached the status of all the windows services on our box.


Interestingly i've seen a few of the Ciscoworks services in a "stopping" state although i've started all services back up and can login ok.


Also i'm not convinced on the startup types of a few of the ciscoworks services as they are set to "Manual" but maybe should be "automatic" ?



Joe Clarke Fri, 04/10/2009 - 11:14
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

It looks like you have potentially quite a few database problems. You MUST NEVER change the service startup types unless explicitly told to do so by TAC. Most of them MUST be Manual.


Reboot this server. After the reboot, wait for the LMS daemons to start fully (can take about 30 minutes). Then run the pdshow command, and post the output.

dmistry21 Fri, 04/10/2009 - 11:22
User Badges:

Thanks Joe. Ok I will arrange for the server to be rebooted and get back to you.


From the attachment do the startup types look correct for the Ciscoworks services ?


Thanks

Joe Clarke Fri, 04/10/2009 - 11:34
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

Yes, they are currently all correct.

dmistry21 Tue, 04/14/2009 - 05:07
User Badges:

I've rebooted the server and all services are now running normally.


Tonight will be the first time the backup runs since the reboot.


I've attached the pdshow output here.



Attachment: 

Actions

This Discussion