VG224 no audio at all

Unanswered Question
Apr 10th, 2009

Hello i have a strange behaviour for this new installation:

1 main site (site 1) with CUCM 6.1, 1 remote site (site 2) with 2811 and VG224 gateways. Both sites are connected with MPLS wan. I use location-based CAC and g729 codec for rtp stream between the 2 sites.

- When a pstn call arrives on site 2 pstn gateway and is directed to dect phones connected on site 2 vg224: dect rings, the call is answered and rtp streams are established correctly.

- But when a call comes from site 1 ip phone to the same dect phone on site 2 vg224: the dect rings, call is answered, the communication is established but there is no audio at all.

It's like rtp packet are not able to cross the wan. But how to explain that site 1 phones can call site 2 phones without problem.

From site 2 vg224, i can ping site 1 ip phone without problem. I try to force mgcp media address without any effect.

I see rtp connection on the vg224:

XXXX-VG224#sh voip rtp connections

VoIP RTP active connections :

No. CallId dstCallId LocalRTP RmtRTP LocalIP RemoteIP

2 3783 3782 18652 23956

I see a g729 call established:

XXXX-VG224#sh voice call status

CallID CID ccVdb Port Slot/DSP:Ch Called # Codec MLPP Dial-peers

0xEC6 1549 0x64A2B998 2/10 0/1:1 * g729br8 0/0

Finally, i can see rtp packet sent and received:

XXXX-VG224#deb voip rtp packet

VOIP RTP All Packets debugging is on

Apr 10 15:04:09.118: RTP(28215): fs rx s=, d=, pt=18, ts=CD1136F5, ssrc=59A9426C

Apr 10 15:04:09.134: RTP(5000): fs tx s=, d=, pt=99, ts=112F5DAB, ssrc=834230B

Apr 10 15:04:09.138: RTP(28216): fs rx s=, d=, pt=18, ts=CD113795, ssrc=59A9426C

Apr 10 15:04:09.162: RTP(28217): fs rx s=, d=, pt=18, ts=CD113835, ssrc=59A9426C

Any help would be appreciated.

Thanks a lot.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Hythim Ali El Hadad Sun, 04/12/2009 - 04:25


Very great share from Chris

This will eliminate any routing or security issues which almost the main reason for cases like this

jtoque Mon, 04/13/2009 - 22:39

Hi, yes i have the mgcp bind command in the configuration.

Thanks for your help.


jtoque Mon, 04/27/2009 - 01:00

Hi, I just find the solution: vg224 mgcp gateway negociate g729br8 codec so i deactivate g729 annex b under callmanager service parameters ("Strip G.729 Annex B (Silence Suppression) from Capabilities"). Now audio calls work well in g729r8




This Discussion