Vlan clarification

Unanswered Question
Apr 10th, 2009

Dear sir,


I have cisco3750 l3 switch and remote i have unmanagble switch.Now i want to creat 3 vlans and that three vlans shouls accesesble to one of the trunk port and i want to know from which vlan traffic is going.

In this setup remote side compalsary l2 switch is require or not.If unmanagble switch is there set up is possible or not.


Plz give me any config examples.

If any body reply this iam very greatfull to him.


srini

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Fri, 04/10/2009 - 07:49

Hello Srini,

if the unmanageable switch is on the path this is a problem: you cannot know if it lets the 802.1Q vlan tagged frames to go through it or not and you cannot configure it.

If it is a leaf not in the main data path you can think to configure the link for carrying three vlans.


you need to make the single physical link a L2 trunk to carry 802.1Q tagged frames.

The L3 switch can provide L3 services using logical SVI interfaces.


example:


L3switch


! create the l2 vlans


conf t

vlan 10

name vlan10

vlan 20

name vlan20

vlan 30

name vlan30


! configure the trunk port


int gi1/0/12

switchport

switchport trunk enc dot1q

switchport mode trunk

switchport trunk allowed vlan 10,20,30

no shut


! create the L3 logical SVI


int vlan 10

ip address 10.10.10.1 255.255.255.0

no shut

int vlan 20

ip address 10.10.20.1 255.255.255.0

no shut

int vlan 30

ip address 10.10.30.1 255.255.255.0

no shut


a manageable L2 switch can be configured to support the 3 vlans and with a trunk configuration on the link towards the L3switch.


Hope to help

Giuseppe


lamav Fri, 04/10/2009 - 07:51

Hello Srini:


This is what I understand from what you are telling us:


You have a 3750 L2 switch that you would like to create 3 VLANs on and have them send traffic through a trunk to an unmanaged switch.


Correct?


If so, I imagine that the unmanagable switch does not allow you to create vlans and segment your LAN. Just taking a guess, it probably places all ports in one pre-configured, untagged vlan.


I would venture to say that if you wanted to connect a Cisco switch to such a fixed configuration switch like the one you have, you would probably have to place all the ports in one vlan and send it on a dotiq trunk on vlan 1, which is also untagged.


Again, I am just taking an educated guess...


So, to answer your question regarding 3 vlans, I would say no. You would have to be able to configure your unmanaged switch with the 3 vlans and allow them on a dot1q trunk.


Maybe someone else has another perspective or experience doing what you want.


HTH


Victor

lamav Fri, 04/10/2009 - 07:53

Giuseppe:


Good afternoon, buddy:


Sorry for the cross post.


Victor

Actions

This Discussion