ilbc codec negotiation with MGCP gateway

Unanswered Question
Apr 10th, 2009
User Badges:
  • Silver, 250 points or more

All,


CUCM version 7.01

2811 MGCP gateway version 12.4(24)T

phone 7962 7942


I am having an issue where want to use ilbc on the call leg from the PRI gateway to the ip phone.


When we dial ip phone to ip phone the call is set to use ilbc and we can see that the phone is successfully negotiating that codec and everything works fine.


When we dial the the DID, the call comes into the MGCP gateway but it seems that the phone and the gateway can not negotiate ilbc. We do have a transcoder on the gateway that is registered and in the MRGL of the gateway but we still can not use ilbc. We also have the regions set so that between the gateway and the ip phone ilbc will be the preferred codec.


A test that we conducted is that we called meeting place, which only supports 711 from our ip phone using ilbc and we can see that the transcoder does get used and there is no problems there. Its just when we want the call to come from the mgcp gateway to the iphone using ilbc that we run into this issue.


Any ideas?



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mattcalderon Fri, 04/10/2009 - 08:00
User Badges:
  • Silver, 250 points or more

We did attempt to put that command on earlier today with no luck. It seems as if the gateway always attempt to connect the call 729 and never negotiates the ilbc codec.


TAC is saying that ilbc is not native to mgcp and thats why 729 ends up being negotiated instead of ilbc but nobody seems to know how to change that.

Tommer Catlin Fri, 04/10/2009 - 13:22
User Badges:
  • Green, 3000 points or more

some of the main reasons to stay away from that codec for now. It has a great design, but being so new, it's not quite widely supported in all versions of cisco gear. I have customers who want to use the ilbc for the wan instead of g729 and I tend to shy away from it for now. We know 729 is tried and true. Until all the bugs are worked out of ilbc, Id stick to 729 and 711.


I know it does not help you, but sometimes the bleeding edge is too much


cheers!

Jonathan Schulenberg Sun, 04/12/2009 - 07:48
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

I went through this with TAC back on 12.4(22)T. I believe that I got it working with these two commands:


mgcp codec ilbc

ccm-manager mgcp codec-all (or something close to that; i forgot the exact syntax)


Also note that iLBC must be enabled on the relevant regions involved in the call on UCM.


Ultimately I had to abandoned this because 22T was so unstable. I would be interested to hear if you have better luck with 24T.

Actions

This Discussion