Fax VG224 2811 CCM 7 MGCP ECM Super G3 not supported?

Unanswered Question
Apr 10th, 2009

I have fax machines connected to a VG224 FXS gateway going out to the telco via a PRI on our 2811 Router. Both gateways are connected to callmanager 7 via MGCP.

I am having issues where faxes to certain remote fax machines do not go through and I get the error on the fax machine of poor line quality. Faxes to the same remote number through an analog line work fine.

I opened a TAC case and they have told me that the new fax machines SuperG3 mode is not supported and I must disable SuperG3 or ECM on every fax machine.

This makes absolutely no sense to me that Cisco will not support a feature on Fax machines that virtually all new fax machines have.

Has anyone else run into this issue and did you find a fix other than disabling SuperG3 ECM on your fax machines? I would think there would be some way to set my gateways to adjust ECM SuperG3 rather than have to manually program each fax machine (100+ fax machines).

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Jonathan Schulenberg Sun, 04/12/2009 - 07:40

You can set this on the gateway. With MGCP it is simple as "mgcp fax-relay sg3-to-g3". ECM is not enabled on the gateway by default I believe. It is controlled by the presence of the "ecm" switch within the "mgcp fax t38 " command.

Cisco IOS Fax, Modem, and Text Support over IP Configuration Guide, Release 12.4T:

http://www.cisco.com/en/US/docs/ios/voice/fax/configuration/guide/vf_cfg_t38_fxrly_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1172262

NPT_2 Mon, 04/13/2009 - 08:17

Thanks for the awesome link. That answered a lot of my questions. One interesting thing though is that if I use the mgcp "fax-relay-sg3-to-g3" command it doesn't work, but if I disable ecm with "no mgcp fax t38 ecm" command it works.

On another note, how do I find out the actual spedd the faxes are connecting at? If I do a show voice call sum it just says t38 and doesn't list a rate.

fernandoaguirre Fri, 04/24/2009 - 10:18

Hi,

I have the same scenario but the vg224 is configured for sccp on callmanager and the voice gateway 2811 with PRI is configured for H323 gateway on callmanager. Voice calls works fine, but fax is not working when connected to fxs ports on vg224. Any ideas on how to solve this???

ryan_bell Fri, 04/17/2009 - 14:32

Hi, I actually have the same setup except using a 2851 router. So far I have followed the t.38 fax relay setup in the link posted here for use in a CA-controlled environment with MGCP. Right now the line works fine for voice, though still no luck sending or receiving faxes. I have also configured the Gateway in CM to use Fax Relay so I am not sure where to go next. Any help in the config thats needed on the gateway and in CM would be great.

Thanks,

Ryan

NPT_2 Fri, 04/17/2009 - 14:44

Here are the following things that I did to get fax relay to work and work at it's fastest speed.

1. Turned off ECM on my VG224 and my 2811 PSTN Gateway with the "no mgcp fax t38 ecm" command.

2. set fax rate to maximum supported 14400 with the "mgcp fax rate 14400" command.

Make sure you have these commands set on both your PSTN gateway and your fax gateway and have fax relay turned on for each. If you don't have it turned on you may want to turn on your mgcp package-capability fxr-package if you don't have it turned on, although I'm not 100% sure if this is required.

Actions

This Discussion