7941G phone will not register with CCM 7.0.2

Unanswered Question
Apr 10th, 2009

I am having issues getting the phone register with the call manager through a firewall. I am not blocking any services and I was able to register the phones to our previous call manager through the same firewall. We have installed a new server 7.0.2 and phones will not register. If I attach the phones to same segment as call manager they will register. Also if I delete the phone and move it to another segment the call manager still shows the previous address.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Chris Deren Sat, 04/11/2009 - 06:37

How is your tftp server determined, do you have a dhcp scope pointing to the correct address?

If you look at the status page on the phone what does it say?

Can you ping the phone from CM server when it's on the other segment?


mjhagen Sat, 04/11/2009 - 08:21

DHCP is disabled and the TFTP server is statically assigned on the phone. I am able to ping the cm server from the other segment. I will look at the status page later.

masaracchia Sat, 04/11/2009 - 06:39

Reset the 7941 IP Phones to the Factory Default and try again.

Complete these steps:


Unplug the power cable from the phone, and then plug in the cable again.

The phone begins its power up cycle.


Immediately press and hold # and while the Headset, Mute, and Speaker buttons begin to flash in sequence, release #.

The line buttons flash in sequence in order to indicate that the phone waits for you to enter the key sequence for the reset.

3.Press 123456789*0# within 60 seconds after the Headset, Mute, and Speaker buttons begin to flash.

If you repeat a key within the sequence, for example, if you press 1223456789*0#, the sequence is still accepted and the phone resets.

If you do not complete this key sequence or do not press any keys, after 60 seconds the Headset, Mute, and Speaker buttons no longer flash, and the phone continues with its normal startup process. The phone does not reset.

If you enter an invalid key sequence, the buttons no longer flash, and the phone continues with its normal startup process. The phone does not reset.

If you enter this key sequence correctly, the phone displays this prompt: upgrading

mjhagen Sat, 04/11/2009 - 08:24

I have taken new phones out of box with no configuration. I apply the ip address and tftp server to phone and it goes through the upgrade. Takes 5 - 10 minutes and still does not register.

mjhagen Mon, 04/13/2009 - 18:59

Issue was solved. It was the SCCP protocol though the firewall. Disabled the ALG for SCCP on the fireall

ecornwell Tue, 06/16/2009 - 14:22

Did something change in CUCM 7.x? I used to run a phone behind my firewall with ALG turned on. Now it doesn't work. (It worked with 4.2)

The firewall does a NAT of the IP address to prevent overlap with the corporate network. (1 to 1 NAT) If I turn the ALG off, I see the actual IP address of the phone instead of the nat'd address.


This Discussion