Back up config to ftp - always gets "Timed out"

Answered Question
Apr 11th, 2009

I have a 1711 running IOS 12.2(7)XR3. It provides the connection and firewall from our private net to the Internet. It is working fine.

I am learning how to back up the config file, I am using ftp: destination. I always get this type of error:

Error writing ftp://someIPAddress/someFileName (Timed out)

Apr 10 17:57:58.114 PDST: FTP: connect failed -- Connection timed out; remote host not responding

I have tried numerous FTP servers and FTP Server implementations, both inside the private network and out in the internet.

My preferred FTP service is a Microsoft one on the local private subnet (FTP is part of Microsoft IIS package). With this FTP service, it appears that the FTP username must be e.g. mydomain.dom\myname. I have tried using the ip ftp username to set that name, as well as including name and password right in the FTP URL. Always I just get "Connection timed out; remote host not responding". Does ftp to a microsoft FTP service work?

I can ping the FTP server no problem.

I have this problem too.
0 votes
Correct Answer by Leo Laohoo about 7 years 6 months ago

Have you tried using TFTP?

Command: copy nvram:startup-config tftp:///

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
DaleKnutsen Sun, 04/12/2009 - 10:54

I installed a TFTPD32 service and that worked! (after getting Windows firewall to cooperate).

Thanks very much for the answer.


This Discussion