Problem with SPA3102: audio connection delay when routing some calls through PSTN line

Unanswered Question
Apr 12th, 2009

Dear Cisco Support,

after searching and searching the web, we have finally chosen the SPA3102 Gateway as the best suitable solution for our company office.
I received the box yesterday, and today I've just started to setup the gateway and understand how it actually works.

- I've set the SPA3102 as a network bridge, and I access the web-based setup page through the WAN port. Everything works fine about networking.
- I've plugged an analogue phone to the PHONE port of the the SPA3102, and then I've connected the PSTN landline to the LINE port of the SPA3102.
- DIAL PLAN: (1xx<:@gw0>|[038]x.<:@gw0>)
I've set this Dial Plan with no Voip usage in order to better figure out where my problem is.

- I've also attached the full "voice" configuration of my SPA3102.

It has not been easy at all, but eventually I've been able to have the SPA3102 to do what we were looking for:

1) we can receive calls from a SIP VoiP account
2) we can route outgoing calls from the analogue phone through a SIP Voip service
3) we can receive incoming calls from the PSTN line through the analogue phone connected to the SPA3102
4) And eventually I can route outgoing calls from the analogue phone through the PSTN line.


- I lift the receiver of the analogue phone connected to PHONE port of the SPA3102
- I dial a number that I know it will be routed through the PSTN line
- the PSTN line gets actually off-hook and engaged by the SPA3102 ("line" led starts flashing)
- the SPA3102 properly dials out the number through the PSTN line
- but the PROBLEM is that the anaolgue phone gets connected to the PSTN line only after some 5 seconds. That is, there is a delay between the dialling start and the audio connection of the phone to the PSTN line. In other words, I start hearing the audio on the PSTN LINE only after a delay of about 5 seconds by the time the call gets answered on the other side. For example, when I try to call a number with an automated answering service, then I always lose the very first 5 seconds of speech.

NB: this kind of issue only happens when dialing short service number with three digits  (e.g. emergency calls, telephone company call centres, and numbers like these starting with digit 1).
Ordinary numbers  (mobile phones, landline phones, toll free numbers, etc) get routed through the PSTN line properly and with no audio-connection delay at all.

I've tried and tried again to change timers and delay parameters...but there was no way to have my issue solved. Now, I really don't know what to do and what to try anymore, I'm really looking forward to getting an help from you!

If there is any further piece of information I can provide you to better understand my problem, please let me know.

Thank you very much,

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Alberto Montilla Mon, 04/13/2009 - 10:18

Dear Franco;

Could you please do the following:

On the dial plan, set the following


On the [PSTN Line] Tab, set the same dial plan

This should set the delay to zero when dialing.


sistemista Tue, 04/28/2009 - 12:12

Hello Alberto,

thank you very much for your quick reply and your help!

I’ve just come back to work after some days spent working out of office.

Now I’ve just re-powered the SPA3102 unit, and re-plugged the PSTN line and the analogue telephone in order to try your suggestions…but I could not try them because there is a problem: the line and phone ports of the SPA3102 seem not to work anymore. It's such a pity.

So, in the meanwhile I have to leave this issue pending, and I’m going to open a new thread about this new issue.

I hope I'll be back soon with the troubleshooting of my Dial Plan issue.

Thank you.


sir_knudde Fri, 04/24/2009 - 00:38

Hi sistemista,

So far I have not been able to get this running. Can you please help me out by sending more details of your configuration? My main problem is routing incomming calls from the PSTN to the analog phone.

Thanks in advance.

Alberto Montilla Fri, 04/24/2009 - 05:59

Dear Sir;

Incoming calls from PSTN to the FXS analog phone should work by default. You only need to connect the PSTN line to the LIne port and the Phone port to the analog phone and power the equipment. Incoming calls are enabled by default, no special configuration is required.


sir_knudde Mon, 04/27/2009 - 12:04

Dear Alberto,

You are right. The calls are being forwarded automatically. That is only until I enter proxy and registration settings for line1. I think I must be doing something wrong: the phone does not even ring when these settings are in place..



Alberto Montilla Tue, 04/28/2009 - 07:00

Dear Sir;

Could you please send the configuration file to amontill at

The following provides indication on how to save configuration




This Discussion