3550 to 3550 connection on cat 5: Crossover or Straight

Unanswered Question
Apr 14th, 2009


I am connecting Cat 3550 EMI (SW1) to Cat 3550 SMI (SW2).

The cable connection is as follows:

1- Sw1 to Patch Panel 1 (Straight)

2- Patch Panel 1 to Patch Panel 2 (Straight)

3- Patch Panel 2 to Sw 2 (Cross over)

The ports are configured as:


interface FastEthernet0/21

description JCITYSW02 trunk connection

switchport trunk encapsulation dot1q

switchport mode trunk

no ip address


Global commands:

spanning-tree mode pvst

spanning-tree extend system-id

Problem is switches are not able to see each other.

What am I missing?

Please help.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
JamesLuther Tue, 04/14/2009 - 06:25

Hello Asif,

In theory your setup looks OK.

Have you tried putting a direct (x-over) cable between the two switches?

Have you tried using a different patch panel interlink?

What does sh int fa0/21 show? ie is it down/down?


hstechcorp Tue, 04/14/2009 - 06:38

No, I did not try putting a direct x-over cable between two switches neither different patch panel interlink.

The output of sh int fa 0/21 shows:

FastEthernet0/21 is up, line protocol is up (connected)

Hardware is Fast Ethernet, address is 000d.28fd.4315 (bia 000d.28fd.4315)

Description: JERCITYSW02 trunk connection

MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation ARPA, loopback not set

Keepalive set (10 sec)

Full-duplex, 100Mb/s

input flow-control is off, output flow-control is off

ARP type: ARPA, ARP Timeout 04:00:00

Last input 00:00:01, output 00:00:00, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: fifo

Output queue :0/40 (size/max)

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute ouxtput rate 0 bits/sec, 0 packets/sec

214205 packets input, 30044425 bytes, 0 no buffer

Received 48145 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

0 watchdog, 40525 multicast, 0 pause input

0 input packets with dribble condition detected

2148548 packets output, 500501024 bytes, 0 underruns

0 output errors, 0 collisions, 11 interface resets

0 babbles, 0 late collision, 0 deferred

0 lost carrier, 0 no carrier, 0 PAUSE output

0 output buffer failures, 0 output buffers swapped out

greg.washburn Tue, 04/14/2009 - 06:39

Are you saying you do not see the partner switch layer 2 mac address when you issue "show mac address-table" or that they cannot see one another at layer 3 IP address?

JamesLuther Tue, 04/14/2009 - 07:04


Your ports are showing up/up. Therefore the switches are connected together OK on a physical layer.

What exactly is the problem?

What does "sh cdp nei" tell you?


hstechcorp Tue, 04/14/2009 - 07:55

Sh Cdp nei does not show the neighboring switch. Sw1 does not Sw2 and vice versa.

hstechcorp Tue, 04/14/2009 - 07:54

I did not check mac table, but I cant ping from one switch to other. The show cdp nei on both switch does not show any entry for other.

greg.washburn Tue, 04/14/2009 - 08:01

I would prefer to use show mac address-table over show cdp neighbor because we do not know that cdp is running (is by default) or that it has not been disabled on a given port.

Having said that can you please show us the output from each switch given the following command:

"show run int vlan 1"

hstechcorp Tue, 04/14/2009 - 08:55

Here is the output:


Building configuration...

Current configuration : 91 bytes


interface Vlan1

ip address

ip helper-address



Current configuration : 91 bytes


interface Vlan1

ip address

ip helper-address


thotsaphon Tue, 04/14/2009 - 09:00



(conf)#cdp run


(conf)#cdp run

I just want to know which one of them is responsible to be a gateway of VLAN1. Are they running as Layer3 switch?


hstechcorp Tue, 04/14/2009 - 09:04

CDP is running as I can see other cisco devices when I do sh cdp nei.

SW1 is the gateway of vlan1.

thotsaphon Tue, 04/14/2009 - 09:11


First of all if the switch1 is responsible to be a gateway of vlan1. At switch2 I would take an ip-helper command off. Please post the configuration of both interfaces from both switches.

Can you use a "show cdp ne" command on both switched and see other switches but these two?


hstechcorp Tue, 04/14/2009 - 09:38

Yes, I can use cdp neighbor but cant see the SW1 from SW2 and vice versa. However, I can see all other cisco devices connected to SW1 or SW2.

I am not on site right now, will post interface config later.


Edison Ortiz Tue, 04/14/2009 - 11:18

1- Sw1 to Patch Panel 1 (Straight)

2- Patch Panel 1 to Patch Panel 2 (Straight)

3- Patch Panel 2 to Sw 2 (Cross over)

Either use 'Straight-through Cabling' to the patch panel on both switches' uplinks or use 'Crossover Cabling' on both.

I haven't seen this type of cabling implemented before and I'm not sure if it's going to work.

With today's auto-mdix implementation, I see 'Straight-through Cabling' implemented across the board.



hstechcorp Wed, 04/15/2009 - 04:34


Thanks for your suggestion. I tried with Straight through cabling first, but connection did not come up. Then I tried with one side of crossover, which was able to bring the connection up for some time. Then it went down.

I think its more of a physical cabling issue, if my configuration is correct. Can you please check the config and let me know if I have any problems there.


Edison Ortiz Wed, 04/15/2009 - 05:55

It can be a problem on the patch panels.

To isolate (I know this will require some manual labor), move one of the switches to the other closet and plug them directly without the patch panel and verify what combination of cables work.

I will guess that will work with both type of cables with the assistance of auto-mdix.

You need to contact whoever built the patch panel so they can come back and fix it.



srue Wed, 04/15/2009 - 06:29

ediortiz, I didn't think the 3550's support automdix.

Edison Ortiz Wed, 04/15/2009 - 06:55


You are right, support for auto-mdix was introduced with 3560s. OP must use crossover for this inter-switch connection.




This Discussion