Intermittent fax issues after MGCP-->H.323 gateway conversion

Unanswered Question
Apr 14th, 2009

Previously we were using MGCP on our gateway to our CUCM but then had to switch to H.323. Faxes were working great with MGCP and we didn't change anything else other than the gateway to CUCM protocol. Now we seem to be experiencing fax issues and we've been troubleshooting this with TAC for over a week now and have run out of ideas. With MGCP we received faxes from these same companies for months. Here's our setup:

Telco--PRI--3825--H.323--CUCM--VG224--Fax Machine

We are trying to pass everything through to our fax machine without touching it.

Attached are the configs for the 3825 and VG224 in question. At this time all calls are coming from the single PRI on the 3825 but the behavior exists on multiple fax machines on multiple VG224s throughout our campus.

Does anyone have any "real world" experience with this and why it could be failing? We are pulling our hair out!! Thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Nicholas Matthews Tue, 04/14/2009 - 18:15


Since MGCP will support SG3 to G3 conversion but H323 does not, this could be a possible difference. Then, the difference between SG3 and G3 is turning the echo canceller off for high speed calls.

What you can try is this on the VG224:

voice-port 2/x

input gain -5

output attenuation 5

What this will do is reduce the amount of echo for high speed faxes, and let the fax machines do the rest.

My guess is that the fax machines were downspeeding too 14.4 or lower with MGCP and are now failing on 33.6 or faster speeds. You can also try lowering the speed on the fax machine to help the issue.



roitsupport Tue, 04/14/2009 - 18:45

Great info - definitely will give it a shot tomorrow and then write back.

Should we also throw in a no echo-cancel enable on the port as well?

roitsupport Wed, 04/15/2009 - 08:43

Nick, after testing your recommendation we found the faxes are still failing. I noticed the phone ringing on the fax machine and caller ID identified the sender, but the fax connection just dropped. Is there anything else we can try?

Nicholas Matthews Wed, 04/15/2009 - 10:03

If you do a 'show call active voice brief' and the calls are switching over to modem passthrough or T38, and there aren't any slips on your T1 or lost packets in the show call active voice brief, fax is very hard to troubleshoot.

At that point you have to get packet captures or PCM captures and listen to the faxes to try and figure out what is going on.

Most faxes fail because of slips, packet loss/jitter, or because they don't switch over.



roitsupport Wed, 04/15/2009 - 13:01

Hello Nick,

Below is the command when we successfully received a fax. Is there anything in particular that we should be looking at or anything that jumps out at you?

VC-DC1-VG224-01#sh call act voi br called-number 118

: hs. + pid:

dur hh:mm:ss tx:/ rx:/

IP : rtt:ms pl:/ms lost://


media inactive detected: media cntrl rcvd: timestamp:

long duration call detected: long duration call duration : timestamp:

MODEMPASS buf:/ loss /

last s dur:/s

FR [int dlci cid] vad: dtmf: seq:

(payload size)

ATM [int vpi/vci cid] vad: dtmf: seq:

(payload size)

Tele (callID) [channel_id] tx://ms noise: acom: i/o:/ dBm

MODEMRELAY info:// xid:/ total://

speeds(bps): local / remote /

Proxy :,,,,, endpt: /

bw: / codec: /

tx: /,/,/

rx: /,/,/

Telephony call-legs: 1

SIP call-legs: 0

H323 call-legs: 0

Call agent controlled call-legs: 0

SCCP call-legs: 0

Multicast call-legs: 0

Media call-legs: 0

Total call-legs: 1

0 : 286614 19257179780ms.1 +7040 pid:0 Originate active

dur 00:00:43 tx:2180/365772 rx:2182/348184

Tele 2/0 (286614) [2/0] tx:32350/32350/0ms g711ulaw noise:-73 acom:69 i/0:-81/-12 dBm

Telephony call-legs: 1

SIP call-legs: 0

H323 call-legs: 0

Call agent controlled call-legs: 0

SCCP call-legs: 0

Multicast call-legs: 0

Media call-legs: 0

Total call-legs: 1


Nicholas Matthews Wed, 04/15/2009 - 13:57

It looks like you switched over to fax because you only have one leg defined here. The other leg will likely show up in 'show call active fax brief'.


roitsupport Wed, 04/15/2009 - 15:05

Hi Nick,

We were finally able to get this solved (as lest it looks like so far)...

Basically we set the speed to 9600, disabled ECM and that took G3 out of the equation and now all faxes seem to be flowing in all directions.

Thanks for the help!!!!

Nicholas Matthews Wed, 04/15/2009 - 17:05

Cool stuff. Glad I could help. Super G3 can throw a wrench into faxing. Our DSPs currently cannot promise V.90 and V.92 speeds, so any time there is a high speed fax or modem working on our DSPs it's best effort. Although, this is something that might be changing soon with some new projects in the next year or so.



This Discussion