Loss of speech during roam with 7921

Unanswered Question
Apr 14th, 2009

I am experiencing several seconds of loss of speech during a roam with the 7921. Any thoughts?

WLC - 4.2.130

1250 and 1240 AP's

7921 v1.2.1

Auth - EAP-FAST with CCKM

Encryp - TKIP

When I debug client mac for the phone I get the following error:

Tue Apr 14 15:01:06 2009: 00:21:a0:24:ad:a9 802.1x 'timeoutEvt' Timer expired for station 00:21:a0:24:ad:a9

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
migilles Tue, 04/14/2009 - 17:20

Ensure that the platinum QoS profile is set for the 792x SSID.

Would suggest to do "debug client " to get more info on the issue.

JON O'NAN Tue, 04/14/2009 - 17:23

Platinum QoS is set as are all parameters required for the 7921 deployment guide.

When I debug client mac for the phone I get the following error:

Tue Apr 14 15:01:06 2009: 00:21:a0:24:ad:a9 802.1x 'timeoutEvt' Timer expired for station 00:21:a0:24:ad:a9

JON O'NAN Wed, 04/29/2009 - 14:26

I am still experiencing this issue and now it is happening at multiple sites. Has anyone else experienced gaps is speech when roaming on the 7921. It only happens on the 802.11a radio.

I have tried the following:

Upgrade to 4.2.176

Adding additional AP density

Using open authentication


migilles Sat, 05/02/2009 - 13:08

Are you using local radius on the WLC?

Also sometimes CCKM may fail with, which could be related to the following, but you are getting timeouts not per say failures.

CSCsx67996 7921/7925 sometimes sending wrong TSF when roaming

CSCsx74467 CLI to enable and disable auto-immune feature

JON O'NAN Sun, 05/03/2009 - 04:32

We are using an enterprise RADIUS. FYI...this a major medical center campus with 2500 access points and 18 controllers.

Would the CCKM issue also occur on 4.2.130? We had only recently upgraded to 4.2.176 as a troubleshooting step per TAC.

I had also seen the auto-immune attacks in the debug mac at one of the sites but not at the main. I will try and disable that feature as a test.


migilles Sun, 05/03/2009 - 22:58

The auto-immune feature doesn't exist in as it was added in In, it is enabled by default and unfortunately no way to disable it. There are future builds planned to disable this by default though. If you are seeing many auto-immune failures then would suggest to contact TAC to assist you further.

JON O'NAN Thu, 05/21/2009 - 17:33

We have been working with TAC for several months on this issue and are narrowing in on a root cause of the gaps in speech. There were several issues including auto-immne attack, PSK bug on 802.11a, TSF bug. We upgraded 7921 firmware from 1.2.1 to 1.3.2 and saw a marked improvement however it was still not acceptable. We are now finding that the older batch of phones are consistently 10 dBm weaker than phones that have been ordered recently. Are there any known differences in hardware of older 7921's vs newer phones. The phones that are having the issue start with MAC address 00:1B and the phones that are working great begin with MAC 00:22.


migilles Tue, 05/26/2009 - 17:52

No differences in the radio or antenna hardware. For the auto-immune issues, suggest that you upgrade to a WLC version that has this feature by default. The latest 4.2 code on CCO has this feature disabled by default.

There is an open intermittent issue when using CCKM, where the TSF can be off by more than 1 second, which can trigger an auto-immune event, where the AP will not respond to the reassociation response and the phone will have to timeout, where it will then have to retry.

I saw a mail from a TAC engineer today asking about the RSSI, but it was stated this was from the AP perspective, so was the tx path of the 7921. The 7921 has a mechanism where it can back off on the tx power if the rx signal is high. So it can override what DTPC is providing and reduce the tx power in an effort to reduce power consumption as well as reduce noise in other areas.

Please provide the RSSI info and the path info to the TAC engineer.


migilles Tue, 05/26/2009 - 17:54

Also if using WPA-PSK, we have seen that the EAPOL can come too quickly sometimes and then it must timeout before it can be retried. The timeout in the current code is 1 second. In the future builds, this will be customizable and will be added to our deployment guides to configure for 200ms.

CSCsq25762 Need capability to reduce the EAPOL-Key Timeout

What worked for me was set EAP request timeout to 20s.

Upgraded to 1.3.2 or higher on the 7921 improved handoff.

Check the 7921 phone RSSI compared to another known good phone. I have to replace or have TAC troubleshoot this. Some phones are consistently 10-20 dbm below the known good phone.

If on high density environments RRM did not work well for me I had a lot of access points on the same channel looking at it from a multifloor model. I manually set channels.

Check wlan session timeout it should be blank for infinity.


JON O'NAN Wed, 08/26/2009 - 05:00

Thanks Michael.

We did resolve this issue a while ago by upgrading to 1.3.2. TAC is attributing this to a TSF bug that is supposed to be resolved in 1.3.3 however we are not quite ready to go to 1.3.3 due to the process with downgrading. The symptoms rarely manifest in 1.3.2. We also saw the 10 dB difference and that went away as well when we upgraded.


migilles Tue, 09/01/2009 - 15:48

We made some RSSI alignments with 7921/7925 in 1.3(3). The TSF issue is when using CCKM with any release after, but pre- and pre-

We recommend, which has this auto-immune feature disabled.

For 1.3(3), we have a transition image that we can provide if it is necesasry to backout to an earlier image, but there were changes that called for this downgrade block.

If you need this image, you can contact and have them reach out to me.


George Stefanick Fri, 09/04/2009 - 17:51


Is there a good site that shows all the bugs for each version? I checked the release notes and there was really much there...



This Discussion